Страница 6 из 6 ПерваяПервая ... 456
Показано с 51 по 54 из 54.

Тема: Конструктор сайтов Site.pro в ISPmanager 5

  1. #51
    Member
    Регистрация
    16.11.2015
    Сообщений
    35

    По умолчанию

    ISPManager 5 + Site.Pro Enterprise

    Сначала поставил модуль со страницы "Модули". Кнопка "Конструктор" вела на урл типа _http://домен-конструктора/ru/?login_hash=758b54528adda679 - как пояснили в Site.Pro, это какой-то "старый" урл, работать не будет, надо сносить модуль и ставить по мануалу.

    Поставил плагин по их мануалу, кнопка конструктора появилась. Ведёт на урл типа

    _https://домен-панели:1500/ispmgr?func=sitepro.open&elid=www-домен-пользователя&plid=&newwindow=yes

    Там ошибка:

    Плагин 'siteprobuilder' завершился с ошибкой или вернул неверный xml


    Правильно ли я понимаю, что новый модуль, вшитый в ISPManager 5 не догоняет Site.Pro, т.к. тот уже обновился и у них что-то стало по-новому; а плагин, предлагаемый на Site.Pro, не догоняет ISPManager?
    Или Site.Pro Enterprise вообще не должен запускаться?

  2. #52
    Support team Аватар для Fly
    Регистрация
    14.08.2010
    Сообщений
    4,751

    По умолчанию

    По-умолчанию кнопка SiteBuilder ведет на сайт site.pro, потому что в бесплатной и Premium версии работа производится на серверах site.pro.

    Если у вас версия Enterprise, то у вас Site.Pro установлен на своем сервере, верно?

    В этом случае нужно задать в файле конфигурации ISPmanager параметры:

    SiteproAffilId=<код партнера в site.pro>
    SiteproUrl=<путь до вашего сервера. до api именно>, например http://site.pro/api/requestLogin
    SiteproPass=<пароль>
    SiteproUser=<пользователь>

    После добавления параметров нужно перезапустить панель - killall core.

    Работу бесплатной версии проверяю - все ок. К сожалению работу модуля с Enterprise версией нет возможности проверить. Поэтому, если у вас после настройки всех параметров возникает проблема в работе модуля, по приведите пожалуйста лог ISPmanager (ispmgr.log) или напишите нам тикет в отдел поддержки.

  3. #53
    Member
    Регистрация
    16.11.2015
    Сообщений
    35

    По умолчанию

    Сделал, спасибо, всё заработало вроде бы )) СПАСИБО

  4. #54
    Junior Member
    Регистрация
    18.06.2016
    Сообщений
    12

    По умолчанию

    У меня ошибка: FTP passive mode should be enabled on your server for website publication to work.
    Возникала из-за того что сервер находился за NAT
    лечение, надо добавить строку в конфигурацию FTP:
    MasqueradeAddress xxx.xxx.xxx.xxx (х = внешний адрес сервера)

Ваши права в разделе

  • Вы не можете создавать новые темы
  • Вы не можете отвечать в темах
  • Вы не можете прикреплять вложения
  • Вы не можете редактировать свои сообщения
  •