Страница 1 из 3 123 ПоследняяПоследняя
Показано с 1 по 10 из 23.

Тема: Обновление нативной версии PHP, как это правильно сделать?

  1. #1
    Senior Member Аватар для Pegas-x
    Регистрация
    16.01.2013
    Сообщений
    330

    Lightbulb Обновление нативной версии PHP, как это правильно сделать?

    Уважаемые разработчики, выложите пожалуйста инструкцию, как правильно обновить нативную версию PHP.
    К примеру у меня стоит версия 5.4, а хотелось бы её обновить до версии 5.5 или выше.
    Как это сделать правильно, чтобы панель потом не глючила?

    Альтернативные версии PHP это конечно замечательно и за это вам респект, но и нативная версия PHP должна периодически обновляться.
    Переустанавливать ради этого панель, не очень хочется, а делать это необходимо.
    Я думаю данный вопрос интересует очень многих владельцев ISPmanager 5

  2. #2
    Senior Member
    Регистрация
    09.04.2013
    Адрес
    Москва
    Сообщений
    1,719

    По умолчанию

    "Правильно" вообще не обновлять
    Почитайте форум, чуть ли не в каждой второй теме пишут представители ISP, что не тестируется панель с пакетами с посторонних репозиториев)
    А в репозиториях ОС, лежит "древняя php"
    Поэтому все обновления на свой "страх и риск"
    Хотя по факту с php там ничего "криминального" не изменится (моё мнение)

  3. #3
    Senior Member
    Регистрация
    20.10.2006
    Адрес
    VTC SPbU
    Сообщений
    713

    По умолчанию

    Цитата Сообщение от Mobiaaa Посмотреть сообщение
    Хотя по факту с php там ничего "криминального" не изменится (моё мнение)
    Главное не с 5.3 уходить, а то пользователи не простят!-)
    По уму между 5.4 и 5.5 проблем со скриптами не должно вылезти, хотя трогать окружение пользователей очень опасно, никогда не знаешь на что они "заточились"...

  4. #4
    Senior Member Аватар для Pegas-x
    Регистрация
    16.01.2013
    Сообщений
    330

    По умолчанию

    Цитата Сообщение от Mobiaaa Посмотреть сообщение
    "Правильно" вообще не обновлять
    Почитайте форум, чуть ли не в каждой второй теме пишут представители ISP, что не тестируется панель с пакетами с посторонних репозиториев)
    Не обновлять как раз нельзя, нативная версия PHP должна быть актуальной для большинства сайтов на сервере.
    Так что правильно как раз обновляться, а как это сделать корректно, по хорошему должны показать разработчики панели!

    Цитата Сообщение от ahk Посмотреть сообщение
    По уму между 5.4 и 5.5 проблем со скриптами не должно вылезти, хотя трогать окружение пользователей очень опасно, никогда не знаешь на что они "заточились"...
    Как раз могут и вылезти, в PHP 5.5 Deprecated функция mysql_query, а её многие до сих пор используют.

  5. #5
    Support team Аватар для Sedna
    Регистрация
    16.05.2014
    Сообщений
    1,557

    По умолчанию

    Уважаемый Mobiaaa ответил вам чистую правду. У нас инструкции нет и мы такое поведение не тестируем. Возможно, кто-то из пользователей захочет поделиться своим опытом.
    Grammar Nazi

  6. #6
    Senior Member Аватар для Pegas-x
    Регистрация
    16.01.2013
    Сообщений
    330

    По умолчанию

    Цитата Сообщение от Sedna Посмотреть сообщение
    Уважаемый Mobiaaa ответил вам чистую правду. У нас инструкции нет и мы такое поведение не тестируем. Возможно, кто-то из пользователей захочет поделиться своим опытом.
    А вот это совсем напрасно, от нативной версии PHP многое зависит. Поскольку альтернативные версии в режиме CGI, дают большую нагрузку на сервер, то соответственно большинство сайтов на сервере, должны работать именно на основной версии PHP. Сейчас версии PHP довольно быстро обновляются и по факту, чтобы не иметь геморроя с панелью и не подставлять "костыли", при изменении основной версии PHP приходится переустанавливать панель, а это согласитесь довольно утомительно.

    Помнится я в свое время поднимал тут на форуме вопрос, об альтернативных версиях PHP (когда еще был ISPmanager 4, вы мою тему еще закрепляли). Вы этот функционал внедрили в ISPmanager 5 и получили серьезный плюс в функциональности вашей панели. Не пора ли задуматься и о том, чтобы разработать функционал ну или мануал как вариант, по изменению нативной версии PHP?

    Вопрос весьма актуальный, посмотрите сколько тем на форуме, так или иначе касаются этого момента.
    Последний раз редактировалось Pegas-x; 30.06.2016 в 18:52.

  7. #7
    Senior Member
    Регистрация
    09.04.2013
    Адрес
    Москва
    Сообщений
    1,719

    По умолчанию

    Цитата Сообщение от ahk Посмотреть сообщение
    Главное не с 5.3 уходить, а то пользователи не простят!-)
    По уму между 5.4 и 5.5 проблем со скриптами не должно вылезти, хотя трогать окружение пользователей очень опасно, никогда не знаешь на что они "заточились"...
    ошибаетесь
    Deprecated mysql_*вылезет
    Сам "сижу" на 5.4
    Болезненно переходили с 5.2 -> 5.3 -> 5.4
    На каждый "апдейт" писали скрипты, которые правили пользователям скрипты, чтобы не было ошибок
    (ereg -> preg_match и т.д.)
    5.5 и выше наверно не в ближайшем будущем пойдёт в работу
    Ибо "задолбут", почему их скрипты в Deprecated уходят

  8. #8
    Senior Member
    Регистрация
    09.04.2013
    Адрес
    Москва
    Сообщений
    1,719

    По умолчанию

    Цитата Сообщение от Pegas-x Посмотреть сообщение
    Не обновлять как раз нельзя, нативная версия PHP должна быть актуальной для большинства сайтов на сервере.
    Так что правильно как раз обновляться, а как это сделать корректно, по хорошему должны показать разработчики панели!
    Цитата Сообщение от Pegas-x Посмотреть сообщение
    Как раз могут и вылезти, в PHP 5.5 Deprecated функция mysql_query, а её многие до сих пор используют.
    эти два Ваших предложения противоречат друг другу
    Как можно держать "актуальную" версию, если в нашем мире большинство скриптов как раз таки "заточено" под mysql_*, *ereg*, session_register (и такое есть) и т.д.
    Тут нужно думать в сторону fastcgi, а не php нативную апать
    Вот этому я был бы очень рад, в частности CloudLinux mod_lsapi
    http://docs.cloudlinux.com/apache_mod_lsapi.html

  9. #9
    Senior Member Аватар для Pegas-x
    Регистрация
    16.01.2013
    Сообщений
    330

    По умолчанию

    Цитата Сообщение от Mobiaaa Посмотреть сообщение
    эти два Ваших предложения противоречат друг другу
    Как можно держать "актуальную" версию, если в нашем мире большинство скриптов как раз таки "заточено" под mysql_*, *ereg*, session_register (и такое есть) и т.д.
    Нисколько, мы ставим на наш VPS только сайты наших клиентов и какие там скрипты, отлично знаем.
    Поэтому просчитать какую версию PHP сейчас актуально ставить, совсем не сложно.

  10. #10
    Senior Member
    Регистрация
    09.04.2013
    Адрес
    Москва
    Сообщений
    1,719

    По умолчанию

    Ну это у Вас)
    А у нас тысячи разношерстных скриптов и всем не угодить
    Да и у других, я думаю, аналогично.
    Поэтому нативная версия сильно не "напрягает"
    Кому надо выше версию, берут CGI

Ваши права в разделе

  • Вы не можете создавать новые темы
  • Вы не можете отвечать в темах
  • Вы не можете прикреплять вложения
  • Вы не можете редактировать свои сообщения
  •