Показано с 1 по 6 из 6

Тема: ISPManager Lite 5 Debian 9, PHP 5.* - нет openssl (--without-openssl')

  1. #1
    Junior Member
    Регистрация
    19.10.2017
    Сообщений
    1

    Question ISPManager Lite 5 Debian 9, PHP 5.* - нет openssl (--without-openssl')

    Доброго времени суток.
    Проблема следующего характера. Ранее использовался сервер с Debian 7 (также ISPManager Lite 5) где все версии PHP (и 5 и 7 ветка) были собраны с openssl, однако после миграции на другой сервер выяснилось, что в текущей системе (ISPManager Lite 5 Debian 9) openssl присутствует только в php 7.0 и 7.1
    Это принципиальное ограничение, или есть способ включить в php5 openssl? Конечная цель - работоспособность обертки https (в частности, file_get_contents). Использовать php7 для некоторых сайтов невозможно ввиду наличия в них зависимости от устаревшего расширения mysql и возможно каких-то других проблем.

  2. #2
    Senior Member
    Регистрация
    17.09.2009
    Сообщений
    187

    По умолчанию

    Цитата Сообщение от driada Посмотреть сообщение
    Доброго времени суток.
    Проблема следующего характера. Ранее использовался сервер с Debian 7 (также ISPManager Lite 5) где все версии PHP (и 5 и 7 ветка) были собраны с openssl, однако после миграции на другой сервер выяснилось, что в текущей системе (ISPManager Lite 5 Debian 9) openssl присутствует только в php 7.0 и 7.1
    Это принципиальное ограничение, или есть способ включить в php5 openssl? Конечная цель - работоспособность обертки https (в частности, file_get_contents). Использовать php7 для некоторых сайтов невозможно ввиду наличия в них зависимости от устаревшего расширения mysql и возможно каких-то других проблем.
    Присоединяюсь, кто вообще додумался опенссл выключить...

  3. #3
    Senior Member
    Регистрация
    17.09.2009
    Сообщений
    187

    По умолчанию

    скомпилил в итоге себе 5.6 с поддержкой ссл. это непросто т.к. 5.6 не умеет опенссл 1.1 но возможно и прекрасно работает.

  4. #4
    Senior Member Аватар для Lazek
    Регистрация
    04.06.2008
    Сообщений
    851

    По умолчанию

    Здравствуйте,

    Вполне возможно, tuupic, сможет прокомментировать этот момент, но лучше сразу создать пожелание на сайте:
    https://features.ispsystem.com

  5. #5
    Support team Аватар для Dasha
    Регистрация
    03.11.2011
    Сообщений
    4,414

    По умолчанию

    В Debian 9 был обновлен openssl и старые версии php не могут его использовать. Поэтому поддержки openssl в Debian9 для 5x php не планируется

  6. #6

    По умолчанию

    isp-php56 последняя поддерживает openssl-1.1 и собрана с ним. Более старые версии уже не поддерживаются разработчиками PHP.

Метки этой темы

Ваши права

  • Вы не можете создавать новые темы
  • Вы не можете отвечать в темах
  • Вы не можете прикреплять вложения
  • Вы не можете редактировать свои сообщения
  •