Показано с 1 по 5 из 5.

Тема: После даунгрейда перестала работать панель

  1. #1
    Junior Member
    Регистрация
    30.11.2017
    Сообщений
    2

    Question После даунгрейда перестала работать панель

    У меня вечная лицензия до версии 5.108. Хостер обновил панель, и лицензия слетела.
    Решил переустановить на более старую версию. Новая не накатывалась сверху, поэтому удалил ее.

    CentOS:
    Код:
    rpm -qa | grep ispmanager
    yum remove ispmanager-lite-common-5.13.0-1.el6.x86_64
    Далее запустил установку:
    Код:
    wget http://cdn.ispsystem.com/install.sh
    sh install.sh ISPmanager --release 5.108
    Прилетела первая ошибка:
    [root@vps~]# sh install.sh ISPmanager --release 5.108
    Installing on REDHAT 7
    System memory:
    total used free shared buff/cache available
    Mem: 1024 96 771 5 155 808
    Swap: 0 0 0

    Disk space:
    Filesystem Size Used Avail Use% Mounted on
    /dev/simfs 30G 16G 15G 51% /

    List of enabled repositories:
    repo id repo name status
    !base/7/x86_64 CentOS-7 - Base 9591
    !epel Extra Packages for Enterprise Linux 7 - x86_64 12246
    !extras/7/x86_64 CentOS-7 - Extras 283
    !ispsystem-5.108 ispsystem-5.108 492
    !ispsystem-base ispsystem-base 591
    !updates/7/x86_64 CentOS-7 - Updates 1134
    !vz-base vz-base 1
    !vz-updates vz-updates 1

    You have incorrect hostname: vps
    Enter new hostname(or Ctrl+C to exit):
    Я ввел название домена:
    You have hostname: site.ru
    What version do you want to install
    1) ISPmanager-Lite with recommended software
    2) ISPmanager-Lite minimal version
    3) ISPmanager-Business

    Choose version: 1

    Chosen: 1

    Checking epel... Epel package already installed
    Checking ispsystem-base repo... Found
    Adding repository ISPsystem..
    Loaded plugins: fastestmirror
    Loading mirror speeds from cached hostfile
    * base: mirror.yandex.ru
    * epel: download.ispsystem.com
    * extras: mirror.yandex.ru
    * ispsystem-5.108: download.ispsystem.com
    * ispsystem-base: download.ispsystem.com
    * updates: mirror.yandex.ru
    Metadata Cache Created
    Loaded plugins: fastestmirror
    Loading mirror speeds from cached hostfile
    * base: mirror.yandex.ru
    * epel: download.ispsystem.com
    * extras: mirror.yandex.ru
    * ispsystem-5.108: download.ispsystem.com
    * ispsystem-base: download.ispsystem.com
    * updates: mirror.yandex.ru
    Package matching coremanager-5.108.0-1.el7.centos.x86_64 already installed. Chec king for update.
    Nothing to do
    install.sh: line 2030: /usr/local/mgr5/sbin/mgrctl: No such file or directory
    Пишет, что все установлено. Но на деле ничего не установлено.
    Ни по
    Код:
    https://ip:1500/ispmgr
    ни по
    Код:
     rpm -qa | grep ispmanager
    ничего не выводит.

  2. #2
    Senior Member Аватар для Lazek
    Регистрация
    04.06.2008
    Сообщений
    780

    По умолчанию

    Здравствуйте,

    В данном случае, Вам необходимо установить нужные Вам пакеты (точнее отсутствующие) - самостоятельно, вручную (по средствам пакетного менеджера).

  3. #3
    Junior Member
    Регистрация
    30.11.2017
    Сообщений
    2

    По умолчанию

    Цитата Сообщение от Lazek Посмотреть сообщение
    Здравствуйте,

    В данном случае, Вам необходимо установить нужные Вам пакеты (точнее отсутствующие) - самостоятельно, вручную (по средствам пакетного менеджера).
    Как мне это сделать? Как я писал выше, установка через официальный скрипт с конкретным выбором дистрибьютива неудачна. Техподдержка хостинга сказала, что установить невозможно более старую версию, если была установлена новая, даже если удалив. Они предложили установить на новый сервер. Уточнив, что даже это не дополнительная услуга, а технически невозможная операция на сервере конкретно с этой панелью.

  4. #4
    Senior Member Аватар для Lazek
    Регистрация
    04.06.2008
    Сообщений
    780

    По умолчанию

    Цитата Сообщение от Markovka Посмотреть сообщение
    Как мне это сделать? Как я писал выше, установка через официальный скрипт с конкретным выбором дистрибьютива неудачна. Техподдержка хостинга сказала, что установить невозможно более старую версию, если была установлена новая, даже если удалив. Они предложили установить на новый сервер. Уточнив, что даже это не дополнительная услуга, а технически невозможная операция на сервере конкретно с этой панелью.
    Наиболее простой вариант:
    1. Сохранить нужные Вам данные.
    2. Переустановить ОС, задать нужное (корректное ) имя сервера.
    3. Установить панель управления, ПРИМЕРНО, следующим образом..

    wget http://cdn.ispsystem.com/install.sh
    sh install.sh --release 5.108 ISPmanager


    Обратите внимание на документацию, как именно необходимо запускать данную команду:

    https://doc.ispsystem.ru/index.php/%...%B5_ISPmanager

    install.sh [options] [mgrname]

    И после этого у Вас установится панель нужной версии.

    Вы в своем логе, пытались устанавливать иначе.

    Если же необходимо продолжить работу на текущем сервере, то необходимо проверить какие пакеты были удалены (можно увидеть в: /var/log/yum.log) и установить их вручную, что-то вроде:
    yum install package_name

    При этом проверяя, что устанавливаются нужные версии пакетов и версии не "пляшут" в разные стороны от COREmanager.

  5. #5
    Support team Аватар для Dasha
    Регистрация
    03.11.2011
    Сообщений
    4,369

    По умолчанию

    А вообще панель не поддерживает даунгрейд. Даже с этими манипуляциями не факт, что заведется.

Ваши права в разделе

  • Вы не можете создавать новые темы
  • Вы не можете отвечать в темах
  • Вы не можете прикреплять вложения
  • Вы не можете редактировать свои сообщения
  •