Показано с 1 по 4 из 4

Тема: Обновление с Ubuntu 14.04.4 LTS до Ubuntu 16.04 LTS

  1. #1
    Member Аватар для Aleksandr.
    Регистрация
    04.05.2016
    Сообщений
    70

    Exclamation Обновление с Ubuntu 14.04.4 LTS до Ubuntu 16.04 LTS

    Здравствуйте.

    сервер - Ubuntu 14.04.4 LTS + ISPmanager Lite 5.135.1 + KernelCare 2.14-2

    подскажите как обновить Ubuntu 14.04.4 LTS до Ubuntu 16.04 LTS, что бы ничего не отвалилось и все работало

    и так же php до PHP 5.6, на сервере нативная версия 5.5.9 (native).

    заранее благодарен за ответ.

  2. #2

    По умолчанию

    Здравствуйте.
    Чтобы ничего не отвалилось прямо - это маловероятно.
    Вкратце: меняются репозитории, потом apt-get update && apt-get dist-upgrade и проверка работоспособности всего и вся с починкой отвалившегося(замена путей в конфигах, установка не подтянувшихся расширений и т.д.).
    Если есть опыт, понимание работы ОС и сервисов - ничего сложного и дел на полчаса-час(с учётом времени скачивания пакетов). Правда, с kernelcare не сталкивался.
    Если опыта нет, то лучше, как и рекомендуется самими разработчиками всех ОС - поставить рядом новый сервер и перенести данные.

    По PHP - в 16.04 уже идёт php-7.0. Если же нужен только PHP новый, то можно просто использовать php-selector

  3. #3
    Member Аватар для Aleksandr.
    Регистрация
    04.05.2016
    Сообщений
    70

    По умолчанию

    Цитата Сообщение от tuupic Посмотреть сообщение
    Здравствуйте.
    Чтобы ничего не отвалилось прямо - это маловероятно.
    Вкратце: меняются репозитории, потом apt-get update && apt-get dist-upgrade и проверка работоспособности всего и вся с починкой отвалившегося(замена путей в конфигах, установка не подтянувшихся расширений и т.д.).
    Если есть опыт, понимание работы ОС и сервисов - ничего сложного и дел на полчаса-час(с учётом времени скачивания пакетов). Правда, с kernelcare не сталкивался.
    Если опыта нет, то лучше, как и рекомендуется самими разработчиками всех ОС - поставить рядом новый сервер и перенести данные.

    По PHP - в 16.04 уже идёт php-7.0. Если же нужен только PHP новый, то можно просто использовать php-selector
    Здравствуйте.

    дело в том, что если я согласно инструкции инструкция меняю на 5.6.19 (alt), то сайт перестает работать. тк PHP 5.6 у меня не native, а (alt).

    В любой случае возможно кто то еще подскажет разумное решения вопроса.

  4. #4

    По умолчанию

    Цитата Сообщение от Aleksandr. Посмотреть сообщение
    Здравствуйте.

    дело в том, что если я согласно инструкции инструкция меняю на 5.6.19 (alt), то сайт перестает работать. тк PHP 5.6 у меня не native, а (alt).

    В любой случае возможно кто то еще подскажет разумное решения вопроса.
    Так смотрите в логе сайта. Модулей каких-либо сайту не хватает, скорее всего.

Ваши права

  • Вы не можете создавать новые темы
  • Вы не можете отвечать в темах
  • Вы не можете прикреплять вложения
  • Вы не можете редактировать свои сообщения
  •