PDA

Просмотр полной версии : Не работают IP на venet0



hirauka
19.02.2010, 04:34
Возникла такая проблема. На новом сервере как и на всех стоит VDSmanager с OpenVZ. При добавлении виртуалок не подхватывает venet0 IP сервера. То есть не пингуется IP и никак не отвечает. Если IP добавлять как интерфейсы, допустим eth0:1 - пингуются. На других серверах сарзу нормально работали IP, на этом не хотят.
Просто несколько серверов на одной подсети, но вилан один и трафик нетегированный.
CentOS 5.4

Igor
19.02.2010, 09:38
покажите /etc/sysctl.conf
сравние его с работающими серверами.

ehfy238
06.03.2010, 10:01
Аналогичная проблема.
Но очень страная.
vdsmanager-linux centos 5.4 x86_64
главный ип
188,188,188,188
Прикрепленые ипы
178,178,178,*
Чвть ипов подсети неработают
178,178,178,51
178,178,178,52
а вот дальше - работают.
178,178,178,88
при попытке подключится к ssh пишет
---------------------------
PuTTY Fatal Error
---------------------------
Network error: Connection refused
---------------------------
ОК
---------------------------

В логах

"error in waitpid(3): nj child processes"

перегрузка сетевых интерфейсов, сервера, vz ничего не дает.
опытным путем выяснил что такая трабла только для некоторых ip.
Если на этом ip установить opensuse то ... - работает!!! подключается.
снова переустанавливаю впс на centos - снова не конектится.
Ипы сами по себе пингуются.
Но по ssh неподключится.
При этом сами центосовские шаблоны чудесно работают на других ипах этого же сервера!
Помогите разобраться.
P/S/ если ставить дебианы то тоже нормально работают на этих ипах.

+ вот такая ошибка
an't read file '/vz/private/33844/etc/shadow'
при попытке установить owl

styx
07.03.2010, 15:03
А шаблоны вы где брали? Все именно выглядит как обычная проблема шаблонов.

ehfy238
09.03.2010, 07:44
шаблоны диска встроеные. то есть те что в "шаблоны Диска"
Еще помогает /etc/init.d/network restart
Скил к сожалению не позволяет разобратся в проблеме(