Страница 1 из 2 12 ПоследняяПоследняя
Показано с 1 по 10 из 12

Тема: Zend Guard

  1. #1
    Senior Member Аватар для dampel
    Регистрация
    10.10.2010
    Сообщений
    637

    Lightbulb Zend Guard

    Здравствуйте подскажите пожалуйста как установить Zend Guard для FreeBSD c php 5.3 ?
    На сколько я понял Zend Optimizer не поддерживает версию php 5.3
    ОС FreeBSD 8x
    PHP 5.3
    ISPmanager Pro
    Если можно обьясните поподробнее. Спасибо
    PS: Если правильнее то он вроде так называется Zend Guard Loader
    Последний раз редактировалось dampel; 12.05.2011 в 02:46.

  2. #2
    Cool UNIX admin Аватар для ls
    Регистрация
    12.03.2007
    Сообщений
    10,471

    По умолчанию

    http://forum.ispsystem.com/ru/showth...ght=Zend+Guard

    Скачать с официального сайта, распаковать куда-либо в /usr/local, прописать в php.ini

  3. #3
    Senior Member Аватар для xaker1
    Регистрация
    30.06.2009
    Сообщений
    2,739

    По умолчанию

    Апну-ка я тему.
    Сделал по вашему совету -
    Код:
    > php -m
    Failed loading /usr/local/lib/php/20060613/ZendGuardLoader.so:  Shared object "libdl.so.2" not found, required by "ZendGuardLoader.so"
    Подскажите, пожалуйста, что не нравится? Точнее как исправить.
    Стоит один раз попробовать что бы влюбиться... в ISP.

    На все мои сообщения, действует конфигурация сервера: ISP Pro (всегда актуальная current версия), FreeBSD 8.0, php as fcgi, nginx+apache.

    Бесплатные плагины для ISPmanager.

  4. #4
    Senior Member
    Регистрация
    13.03.2010
    Сообщений
    147

    По умолчанию

    Лоадер запрашивает libdl.so.2, которого нет у вас в системе.

  5. #5
    Senior Member Аватар для xaker1
    Регистрация
    30.06.2009
    Сообщений
    2,739

    По умолчанию

    Спасибо, Кэп!
    Установил Linux библиотеки, теперь
    Код:
    Failed loading /usr/local/lib/php/20060613/ZendGuardLoader.so:  /lib/libdl.so.2: unsupported file layout
    [
    Стоит один раз попробовать что бы влюбиться... в ISP.

    На все мои сообщения, действует конфигурация сервера: ISP Pro (всегда актуальная current версия), FreeBSD 8.0, php as fcgi, nginx+apache.

    Бесплатные плагины для ISPmanager.

  6. #6
    Senior Member
    Регистрация
    13.03.2010
    Сообщений
    147

    По умолчанию

    Шаг 1.
    А что-то мне подсказывает что вы попытались поставить модули от разных систем в плане битности. х86 и х64 не спутали между собой?

    Если ничего такого не было, то шаг 2.
    Порты давно обновляли? Как вариант поставить библиотеку SDL.
    Последний раз редактировалось mhost; 03.10.2011 в 02:40.

  7. #7
    Cool UNIX admin Аватар для ls
    Регистрация
    12.03.2007
    Сообщений
    10,471

    По умолчанию

    А он разве под FreeBSD есть? Вы какой конкретно файл качали? Возможно надо поставить linux_base (не уверен что вы поставили то что нужно)

  8. #8
    Senior Member Аватар для Виктор
    Регистрация
    27.08.2008
    Адрес
    MGNHost.ru
    Сообщений
    3,256

    По умолчанию

    xaker1, а с каких пор Zend Guard Loader стал доступен под FreeBSD ?
    Zend вроде бы вообще отказался от поддержки вряхи и на сколько мне известно, под фряху его ещё не выпускали.

  9. #9
    Senior Member Аватар для xaker1
    Регистрация
    30.06.2009
    Сообщений
    2,739

    По умолчанию

    Цитата Сообщение от ls Посмотреть сообщение
    А он разве под FreeBSD есть? Вы какой конкретно файл качали? Возможно надо поставить linux_base (не уверен что вы поставили то что нужно)
    Linux_base стоит.
    Цитата Сообщение от Виктор Посмотреть сообщение
    xaker1, а с каких пор Zend Guard Loader стал доступен под FreeBSD ?
    Zend вроде бы вообще отказался от поддержки вряхи и на сколько мне известно, под фряху его ещё не выпускали.
    Нету. Поэтому и пытаюсь линуксовую сборку поставить.

    Цитата Сообщение от mhost Посмотреть сообщение
    Шаг 1.
    А что-то мне подсказывает что вы попытались поставить модули от разных систем в плане битности. х86 и х64 не спутали между собой?

    Если ничего такого не было, то шаг 2.
    Порты давно обновляли? Как вариант поставить библиотеку SDL.
    По битности верный файл качал. Порты новые. SDL попробую
    Стоит один раз попробовать что бы влюбиться... в ISP.

    На все мои сообщения, действует конфигурация сервера: ISP Pro (всегда актуальная current версия), FreeBSD 8.0, php as fcgi, nginx+apache.

    Бесплатные плагины для ISPmanager.

  10. #10
    Cool UNIX admin Аватар для ls
    Регистрация
    12.03.2007
    Сообщений
    10,471

    По умолчанию

    Сообщите о результате пожалуйста, я лично так как ставил на Linux его только - там проблем никаких не было вообще.

Ваши права

  • Вы не можете создавать новые темы
  • Вы не можете отвечать в темах
  • Вы не можете прикреплять вложения
  • Вы не можете редактировать свои сообщения
  •