Показано с 1 по 6 из 6

Тема: Internal server Error или Options -Multiviews

  1. #1
    Junior Member
    Регистрация
    28.08.2011
    Сообщений
    20

    По умолчанию Internal server Error или Options -Multiviews

    Здравствуйте, Хочу перейти на свой vds. поставил ISPmanagerLite. После перехода выходит ошибка Internal Server Error

    The server encountered an internal error or misconfiguration and was unable to complete your request.

    Please contact the server administrator, webmaster@***.ru and inform them of the time the error occurred, and anything you might have done that may have caused the error.

    More information about this error may be available in the server error log.

    Apache/2.2.3 (CentOS) Server at ***** Port 80. Если удалить файл .htaccess то Ошибка в типе содержимого. Страница, которую вы пытаетесь просмотреть, не может быть показана, так как она использует неверную или неподдерживаемую форму компрессии.

    Настройки PHP стоит на максимуме. Если поставить чистый двиг то работает нормально. Как исправить данную проблему? Извините я новичок в этом

  2. #2
    Junior Member
    Регистрация
    28.08.2011
    Сообщений
    20

    По умолчанию

    Вот логи ошибок
    [Sun Aug 28 11:38:03 2011] [alert] [client 217.212.230.20] /var/www/nur/data/www/****.ru/.htaccess: Option Multiviews not allowed here
    [Sun Aug 28 11:42:21 2011] [alert] [client 217.212.230.20] /var/www/nur/data/www/*****.ru/.htaccess: AllowOverride not allowed here

    А в .htaccses есть Options -Multiviews Если его прокомментировать # то компрессия слетает

  3. #3
    Cool UNIX admin Аватар для ls
    Регистрация
    12.03.2007
    Сообщений
    10,471

    По умолчанию

    Уберите просто слово Multiviews в .htaccess, ничего никуда не слетит. Либо разрешите в конфиге Apache в описании Directory для домена или разрешите включать глобально в /etc/httpd/conf.d/secure.conf

  4. #4
    Junior Member
    Регистрация
    28.08.2011
    Сообщений
    20

    По умолчанию

    Спасибо ограмное, апачи настроил и .htaccess помогло!

  5. #5
    Junior Member
    Регистрация
    16.05.2012
    Сообщений
    4

    По умолчанию

    Разрешить MultiViews можно исправив в файле /etc/httpd/conf.d
    /secure.conf

    Строку
    Код:
    AllowOverride FileInfo AuthConfig Limit Indexes Options
    на
    Код:
    AllowOverride FileInfo AuthConfig Limit Indexes Options=All,MultiViews

  6. #6
    Junior Member
    Регистрация
    26.03.2013
    Сообщений
    10

    По умолчанию

    Цитата Сообщение от vld Посмотреть сообщение
    Разрешить MultiViews можно исправив в файле /etc/httpd/conf.d
    /secure.conf

    Строку
    Код:
    AllowOverride FileInfo AuthConfig Limit Indexes Options
    на
    Код:
    AllowOverride FileInfo AuthConfig Limit Indexes Options=All,MultiViews
    Спасибо за пример! Заработало.

Ваши права

  • Вы не можете создавать новые темы
  • Вы не можете отвечать в темах
  • Вы не можете прикреплять вложения
  • Вы не можете редактировать свои сообщения
  •