Показано с 1 по 8 из 8

Тема: FastCGI + Apache + billing

  1. #1
    Senior Member
    Регистрация
    09.04.2013
    Адрес
    Москва
    Сообщений
    2,101

    По умолчанию FastCGI + Apache + billing

    Здравствуйте.
    Появилась вот такая проблема.
    Имею dedicated с CloudLinux + Apache+FastCGI+Ispmanager PRO 4.4.10.17
    А проблема вот в чём.
    Скриптом (PHP) добавляется пользователь в ISpmanager
    Пользователь создаётся, но вот скрипт php крашится с ошибкой "502 Bad Gateway"
    И в логах видно одну единственную строчку
    (22)Invalid argument: mod_fcgid: can't lock process table in pid (тут pid процессов меняется)...
    Как с этим бороться??

  2. #2

    По умолчанию

    Если мне не изменяет память, ошибка возникает при нехватке памяти...

  3. #3
    Senior Member
    Регистрация
    09.04.2013
    Адрес
    Москва
    Сообщений
    2,101

    По умолчанию

    гигов 20-25 свободно.
    Причину нашёл и решил.
    Тему офф..
    Виноват FastCGI

  4. #4
    Senior Member
    Регистрация
    26.06.2009
    Сообщений
    767

    По умолчанию

    Нет, виноват не FastCGI, а тот кто его настраивал (или не настраивал).

  5. #5
    Senior Member
    Регистрация
    09.04.2013
    Адрес
    Москва
    Сообщений
    2,101

    По умолчанию

    ну тогда значит у CloudLinux FastCGI не правильный)
    Который умирает вместе со скриптом

  6. #6
    Senior Member
    Регистрация
    26.06.2009
    Сообщений
    767

    По умолчанию

    Mobiaaa, любой софт который бы вы не ставили нужно настраивать.
    Не хотите, не умеете, наймите администратора. "Из коробка" почти ничего не работает так как вы хотите.

  7. #7
    Senior Member
    Регистрация
    09.04.2013
    Адрес
    Москва
    Сообщений
    2,101

    По умолчанию

    Ставила поддерка CloudLinux/
    Они же отписали в тикеты, что FastCGI для него это свойственно.
    Тема вообще уже давно исчерпана костылями

  8. #8
    Senior Member
    Регистрация
    26.06.2009
    Сообщений
    767

    По умолчанию

    Ставил использовал, обычная настройка FastCGI, все летает и без ошибок.
    Чего то там недокрутили!

    И я уверен на 99.9% что поддержка CloudLinux ставила систему но никакой софт они не настраивали. Установить клауд и запустить его это одно, а настроить ПО это другое.

Ваши права

  • Вы не можете создавать новые темы
  • Вы не можете отвечать в темах
  • Вы не можете прикреплять вложения
  • Вы не можете редактировать свои сообщения
  •