Показано с 1 по 6 из 6

Тема: Nginx не пускает к phpmyadmin

  1. #1
    Junior Member
    Регистрация
    11.10.2014
    Сообщений
    6

    По умолчанию Nginx не пускает к phpmyadmin

    phpmyadmin ставил через панель, при активированном nginx получаю



    Вырубаю nginx - вхожу в phpmyadmin без проблем.
    CentOS 6.5 x64, панель ISPmanager 5.19.7

    Подскажите, куда тут копать?
    Последний раз редактировалось MGV; 11.10.2014 в 01:41.

  2. #2
    Member Аватар для orient
    Регистрация
    18.03.2014
    Сообщений
    99

    По умолчанию

    Здравствуйте!
    Покажите, пожалуйста, содержимое следующих файлов при включенном nginx:
    /etc/nginx/vhosts-includes/phpmyadmin.conf
    /etc/httpd/conf.d/phpmyadmin.conf
    /usr/local/mgr5/etc/ispmgr.conf.d/myadmin.conf

    Также покажите выводы команд:
    netstat -nap | grep httpd
    netstat -nap | grep nginx
    ls -la /etc/phpMyAdmin/servers.ini.php
    Последний раз редактировалось orient; 12.10.2014 в 10:18.

  3. #3
    Junior Member
    Регистрация
    11.10.2014
    Сообщений
    6

    По умолчанию

    Цитата Сообщение от orient Посмотреть сообщение
    Покажите, пожалуйста, содержимое следующих файлов при включенном nginx:
    /etc/nginx/vhosts-includes/phpmyadmin.conf
    PHP код:
    location /phpmyadmin {
        
    alias /usr/share/phpMyAdmin;
        
    index index.php;
    }
    location ~* ^/phpmyadmin/(.+\.(jpg|jpeg|gif|css|png|js|ico|html|xml|txt))$ {
        
    alias /usr/share/phpMyAdmin/$1;
        
    error_page 404 @apache;
    }
    location ~ ^/phpmyadmin/(.+\.php)$ {
        
    alias /usr/share/phpMyAdmin/$1;
        
    fastcgi_pass unix:/var/run/php-fpm.apache.sock;
        
    fastcgi_index index.php;
        
    fastcgi_param SCRIPT_FILENAME $request_filename;
        include 
    fastcgi_params;
        
    error_page 502 =200 @apache;
        
    error_page 404 @apache;
    }
    location @apache {
        
    error_log off;
        
    proxy_pass http://127.0.0.1:8080;
        
    proxy_redirect http://127.0.0.1:8080 /;
        
    proxy_set_header Host $host;
        
    proxy_set_header X-Forwarded-For $proxy_add_x_forwarded_for;
        
    proxy_set_header X-Forwarded-Proto $scheme;

    Цитата Сообщение от orient Посмотреть сообщение
    /etc/httpd/conf.d/phpmyadmin.conf
    PHP код:
    Alias /phpmyadmin /usr/share/phpMyAdmin
    <Directory /usr/share/phpMyAdmin>
        <
    IfModule itk.c>
            
    AssignUserID apache apache
        
    </IfModule>
        
    Order allow,deny
        Allow from all
        Options FollowSymLinks
        DirectoryIndex index
    .php
        
    <IfModule php5_module>
            
    AddType application/x-httpd-php .php  .php3 .php4 .php5 .phtml
            php_flag magic_quotes_gpc Off
            php_flag track_vars On
            php_flag register_globals Off
            php_admin_flag allow_url_fopen Off
            php_admin_flag engine on
            php_value include_path 
    .
            
    php_admin_value upload_tmp_dir /tmp
            php_admin_value open_basedir 
    "/usr/share/phpMyAdmin/:/etc/phpMyAdmin/:/var/lib/phpmyadmin/:/tmp/:/usr/share/php/:/var/lib/php/session/"
            
    php_admin_value session.save_path "/var/lib/php/session"
        
    </IfModule>
        
    RemoveHandler .php .php3 .php4 .phtml
        
    <FilesMatch "\.ph(p[3-5]?|tml)$">
            
    SetHandler application/x-httpd-php
        
    </FilesMatch>
    </
    Directory
    Цитата Сообщение от orient Посмотреть сообщение
    /usr/local/mgr5/etc/ispmgr.conf.d/myadmin.conf
    PHP код:
    path phpmyadmin-servers /etc/phpMyAdmin/servers.ini.php
    extaction phpmyadmin http
    ://$site/phpmyadmin/ 

    Цитата Сообщение от orient Посмотреть сообщение
    Также покажите выводы команд:
    netstat -nap | grep httpd


    Цитата Сообщение от orient Посмотреть сообщение
    netstat -nap | grep nginx


    Цитата Сообщение от orient Посмотреть сообщение
    ls -la /etc/phpMyAdmin/servers.ini.php

  4. #4
    Junior Member
    Регистрация
    11.10.2014
    Сообщений
    6

    По умолчанию

    Вот что видно:

    Цитата Сообщение от orient Посмотреть сообщение
    /etc/nginx/vhosts-includes/phpmyadmin.conf
    location /phpmyadmin {
    alias /usr/share/phpMyAdmin;
    index index.php;
    }
    location ~* ^/phpmyadmin/(.+\.(jpg|jpeg|gif|css|png|js|ico|html|xml|txt))$ {
    alias /usr/share/phpMyAdmin/$1;
    error_page 404 @apache;
    }
    location ~ ^/phpmyadmin/(.+\.php)$ {
    alias /usr/share/phpMyAdmin/$1;
    fastcgi_pass unix:/var/run/php-fpm.apache.sock;
    fastcgi_index index.php;
    fastcgi_param SCRIPT_FILENAME $request_filename;
    include fastcgi_params;
    error_page 502 =200 @apache;
    error_page 404 @apache;
    }
    location @apache {
    error_log off;
    proxy_pass http://127.0.0.1:8080;
    proxy_redirect http://127.0.0.1:8080 /;
    proxy_set_header Host $host;
    proxy_set_header X-Forwarded-For $proxy_add_x_forwarded_for;
    proxy_set_header X-Forwarded-Proto $scheme;
    }

    Цитата Сообщение от orient Посмотреть сообщение
    /etc/httpd/conf.d/phpmyadmin.conf
    Alias /phpmyadmin /usr/share/phpMyAdmin
    <Directory /usr/share/phpMyAdmin>
    <IfModule itk.c>
    AssignUserID apache apache
    </IfModule>
    Order allow,deny
    Allow from all
    Options FollowSymLinks
    DirectoryIndex index.php
    <IfModule php5_module>
    AddType application/x-httpd-php .php .php3 .php4 .php5 .phtml
    php_flag magic_quotes_gpc Off
    php_flag track_vars On
    php_flag register_globals Off
    php_admin_flag allow_url_fopen Off
    php_admin_flag engine on
    php_value include_path .
    php_admin_value upload_tmp_dir /tmp
    php_admin_value open_basedir "/usr/share/phpMyAdmin/:/etc/phpMyAdmin/:/var/lib/phpmyadmin/:/tmp/:/usr/share/php/:/var/lib/php/session/"
    php_admin_value session.save_path "/var/lib/php/session"
    </IfModule>
    RemoveHandler .php .php3 .php4 .phtml
    <FilesMatch "\.ph(p[3-5]?|tml)$">
    SetHandler application/x-httpd-php
    </FilesMatch>
    </Directory>

    Цитата Сообщение от orient Посмотреть сообщение
    /usr/local/mgr5/etc/ispmgr.conf.d/myadmin.conf
    path phpmyadmin-servers /etc/phpMyAdmin/servers.ini.php
    extaction phpmyadmin http://$site/phpmyadmin/

    Цитата Сообщение от orient Посмотреть сообщение
    netstat -nap | grep httpd
    tcp 0 0 127.0.0.1:8080 0.0.0.0:* LISTEN 8057/httpd.itk
    tcp 0 0 89.108.85.57:1500 0.0.0.0:* LISTEN 24933/./sbin/ihttpd

    Цитата Сообщение от orient Посмотреть сообщение
    netstat -nap | grep nginx
    tcp 0 0 0.0.0.0:80 0.0.0.0:* LISTEN 8054/nginx
    tcp 0 0 89.108.85.102:80 5.255.253.98:55748 ESTABLISHED 8195/nginx
    unix 3 [ ] STREAM CONNECTED 410196 8054/nginx
    unix 3 [ ] STREAM CONNECTED 410195 8054/nginx

    Цитата Сообщение от orient Посмотреть сообщение
    ls -la /etc/phpMyAdmin/servers.ini.php
    -rw-r--r-- 1 root root 141 Oct 10 18:35 /etc/phpMyAdmin/servers.ini.php

  5. #5
    Junior Member
    Регистрация
    11.10.2014
    Сообщений
    6

    По умолчанию

    Отключил в панели nginx - убились все настройки доменов. Все чудесатее и чудесатее.
    Причем отключал до этого - такого не было, ничего не слетало.

  6. #6
    ISPsystem team Аватар для usaafko
    Регистрация
    06.10.2013
    Сообщений
    2,384

    По умолчанию

    Напишите запрос в поддержку, посмотрим в чем проблема

Ваши права

  • Вы не можете создавать новые темы
  • Вы не можете отвечать в темах
  • Вы не можете прикреплять вложения
  • Вы не можете редактировать свои сообщения
  •