Страница 3 из 4 ПерваяПервая 1234 ПоследняяПоследняя
Показано с 21 по 30 из 38

Тема: MariaDB

  1. #21
    Senior Member
    Регистрация
    22.12.2013
    Сообщений
    157

    По умолчанию

    Перечитал вроде бы все темы, которые нашлись в поиске по MariaDB. Так и не понял до конца как же перейти на нее.

    Подскажите, можно ли руками обновить просто MySql на MariaDB, или будут потом проблемы с панелью? Или же все таки есть какой то другой более правильный путь перехода?
    Debian 8, ISP Manager 5 Lite, Nginx + Apache / Mod-PHP

  2. #22
    Senior Member
    Регистрация
    15.10.2014
    Сообщений
    194

    По умолчанию

    Цитата Сообщение от nevigen Посмотреть сообщение
    можно ли руками обновить просто MySql на MariaDB, или будут потом проблемы с панелью?
    Можно. Проблем нет. Только на дашборде не будет инфы о версии mysql, всего-то.

  3. #23
    Senior Member
    Регистрация
    22.12.2013
    Сообщений
    157

    По умолчанию

    Спасибо. Версия на дашборде меньше всего волнует Главное чтобы функционал остался. Монитор например, и так далее.
    Debian 8, ISP Manager 5 Lite, Nginx + Apache / Mod-PHP

  4. #24
    Senior Member
    Регистрация
    09.04.2013
    Адрес
    Москва
    Сообщений
    2,035

    По умолчанию

    Цитата Сообщение от nevigen Посмотреть сообщение
    Спасибо. Версия на дашборде меньше всего волнует Главное чтобы функционал остался. Монитор например, и так далее.
    На 4 к примеру, после смены на марию, "отвалилась" возможность восстанавливать базы с бекапа, так как панель отправляла директиву кодировки, которая не поддерживается maria 10.1

  5. #25
    Senior Member
    Регистрация
    22.12.2013
    Сообщений
    157

    По умолчанию

    у меня 5-я. уже обновился, вроде все работает тестировал, конечно впечатлило. в некоторых случаях производительность x3
    Debian 8, ISP Manager 5 Lite, Nginx + Apache / Mod-PHP

  6. #26
    Senior Member
    Регистрация
    16.10.2010
    Сообщений
    1,652

    По умолчанию

    Поднему вопрос...немного
    И так насколько я помню .. чтобы все прошло Ок .. то дистр isp должен видеть mysql сервер по какойто строке.. чтоюы пакеты isp неругались на зависимости
    К чему спрашиваю... хочу поставить yum repo mysql и поставить впесто 5.1 версию 5.6 или 5.7... а вот как проверить эти пакеты на совместитьмость

  7. #27
    Senior Member
    Регистрация
    09.04.2013
    Адрес
    Москва
    Сообщений
    2,035

    По умолчанию

    Цитата Сообщение от HappyAlex Посмотреть сообщение
    Поднему вопрос...немного
    И так насколько я помню .. чтобы все прошло Ок .. то дистр isp должен видеть mysql сервер по какойто строке.. чтоюы пакеты isp неругались на зависимости
    К чему спрашиваю... хочу поставить yum repo mysql и поставить впесто 5.1 версию 5.6 или 5.7... а вот как проверить эти пакеты на совместитьмость
    При конфликте пакетов писал в поддержку CloudLinux, они допилиливали свои модификации, чтобы провайдился mysql-compat-server, видимо по нём и тянутся пакеты нужные для базы
    Но это касательно зависимостей yum, а что там в самой панели заложено, может по имени пакета...

  8. #28
    Senior Member
    Регистрация
    16.10.2010
    Сообщений
    1,652

    По умолчанию

    Насколько я понял нужно сделать yum provides mysql-server
    И если нужный дистр mysql-server это дает.. то все должно быть ок

    Я так делал на тестовом стенде менял 5.1 на 5.5 из реми репозитария. Потом обновлял панель и все было гудно в плане обновления

  9. #29
    Senior Member
    Регистрация
    09.04.2013
    Адрес
    Москва
    Сообщений
    2,035

    По умолчанию

    Цитата Сообщение от HappyAlex Посмотреть сообщение
    Насколько я понял нужно сделать yum provides mysql-server
    И если нужный дистр mysql-server это дает.. то все должно быть ок

    Я так делал на тестовом стенде менял 5.1 на 5.5 из реми репозитария. Потом обновлял панель и все было гудно в плане обновления
    этого мало)
    У меня к примеру на ISP 4 при обновлении mysql 5.1 -> mariadb10/percona 5.6 (Была перкона, заменил на пакет марии от CloudLinux)
    Так вот после update отвалился модуль восстановления баз, так как в свежих версиях другой синтаксис установки кодировки
    Вот про это я имел ввиду, не поломается ли в самой панели что-то

  10. #30
    Senior Member
    Регистрация
    16.10.2010
    Сообщений
    1,652

    По умолчанию

    Mobiaaa
    хммм... у меня тоже есть isp 4 cluster и юзаю там 5.5.32-MariaDB вместо mysql server - тьфц тьфу все ОК
    . возможно проблема более в высокой версии mariadb

    вот что лучше поставить вместо 5.1
    машку 10 или машку 5.5 - из репов машки
    yum provides mysql-server
    MariaDB-server-10.0.24-1.el6.x86_64 : MariaDB: a very fast and robust SQL database server
    Repo : mariadb
    Matched from:
    Other : mysql-server
    или же поставить mysql5.6(5.7)
    mysql-community-server-5.6.29-2.el6.x86_64 : A very fast and reliable SQL database server
    Repo : mysql56-community
    Matched from:
    Other : mysql-server

    из репов mysql

    при переходе с 5.1 ... кто что ставил и как стало ?

    Спасибо
    Последний раз редактировалось HappyAlex; 25.02.2016 в 11:04.

Метки этой темы

Ваши права

  • Вы не можете создавать новые темы
  • Вы не можете отвечать в темах
  • Вы не можете прикреплять вложения
  • Вы не можете редактировать свои сообщения
  •