Страница 1 из 2 12 ПоследняяПоследняя
Показано с 1 по 10 из 15

Тема: Обновление до 5.33.0: Пропал выбор PHP для FastCGI

  1. #1
    Junior Member
    Регистрация
    22.07.2015
    Сообщений
    15

    По умолчанию Обновление до 5.33.0: Пропал выбор PHP для FastCGI

    Добрый день!
    После обновления ISPmanager Lite с 5.32.1 до 5.33.0 для FastCGI пропала возможность выбора версии PHP у конкретного домена в разделе WWW-домены (Для CGI возможность осталась).

  2. #2
    Support team Аватар для usaafko
    Регистрация
    06.10.2013
    Сообщений
    2,384

    По умолчанию

    FastCGI работает по другому приниципу. У вас используется связка Nginx+PHP-FPM?

  3. #3
    Junior Member
    Регистрация
    22.07.2015
    Сообщений
    15

    По умолчанию

    Цитата Сообщение от usaafko Посмотреть сообщение
    FastCGI работает по другому приниципу. У вас используется связка Nginx+PHP-FPM?
    Да.
    Update: У меня был FastCGI (Apache) , но после обновления он куда-то пропал из доступных вариантов (и вместо него был, видимо, автоматически выбран Nginx+PHP-FPM)...
    Последний раз редактировалось MaximWRC; 23.07.2015 в 00:08.

  4. #4
    Support team Аватар для usaafko
    Регистрация
    06.10.2013
    Сообщений
    2,384

    По умолчанию

    php-fpm - это запущенный сервис, поэтому менять его версию не получится. Селектор работает только для режима CGI, где php запускается через врапер, который можно менять на лету
    Цитата Сообщение от MaximWRC Посмотреть сообщение
    (и вместо него был, видимо, автоматически выбран Nginx+PHP-FPM)...
    странно. В возможностях apache установлен с mpm-itk?

  5. #5
    Junior Member
    Регистрация
    22.07.2015
    Сообщений
    15

    По умолчанию

    Цитата Сообщение от usaafko Посмотреть сообщение

    странно. В возможностях apache установлен с mpm-itk?
    Да. Доступ в Панель разрешен, если это поможет...

    Судя по комментарию техподдержки хостинга, которая делала обновление, в процессе обновления возникли конфликты:
    Код:
    Error: ispmanager-pkg-httpd conflicts with ispmanager-pkg-httpd-itk-5.33.0-1.el6.x86_64
    Error: ispmanager-pkg-httpd-itk conflicts with ispmanager-pkg-httpd-5.33.0-1.el6.x86_64
    Error: ispmanager-pkg-pureftpd conflicts with ispmanager-pkg-proftpd-5.33.0-1.el6.x86_64
    Error: ispmanager-pkg-proftpd conflicts with ispmanager-pkg-pureftpd-5.33.0-1.el6.x86_64
    
    Обновили до 5.33.0-1
    coremanager.x86_64                   5.33.0-1.el6                @ispsystem-beta
    coremanager-pkg-bind.x86_64          5.33.0-1.el6                @ispsystem-beta
    coremanager-pkg-mysql.x86_64         5.33.0-1.el6                @ispsystem-beta
    coremanager-pkg-php.x86_64           5.33.0-1.el6                @ispsystem-beta
    ispmanager-lite.x86_64               5.33.0-1.el6                @ispsystem-beta
    ispmanager-lite-common.x86_64        5.33.0-1.el6                @ispsystem-beta
    ispmanager-pkg-awstats.x86_64        5.33.0-1.el6                @ispsystem-beta
    ispmanager-pkg-bind.x86_64           5.33.0-1.el6                @ispsystem-beta
    ispmanager-pkg-dovecot.x86_64        5.33.0-1.el6                @ispsystem-beta
    ispmanager-pkg-exim.x86_64           5.33.0-1.el6                @ispsystem-beta
    ispmanager-pkg-httpd-itk.x86_64      5.33.0-1.el6                @ispsystem-beta
    ispmanager-pkg-logrotate.x86_64      5.33.0-1.el6                @ispsystem-beta
    ispmanager-pkg-myadmin.x86_64        5.33.0-1.el6                @ispsystem-beta
    ispmanager-pkg-mysql.x86_64          5.33.0-1.el6                @ispsystem-beta
    ispmanager-pkg-nginx.x86_64          5.33.0-1.el6                @ispsystem-beta
    ispmanager-pkg-php.x86_64            5.33.0-1.el6                @ispsystem-beta
    ispmanager-pkg-phpext-ioncube.x86_64 5.33.0-1.el6                @ispsystem-beta
    ispmanager-pkg-phpfpm.x86_64         5.33.0-1.el6                @ispsystem-beta
    ispmanager-pkg-proftpd.x86_64        5.33.0-1.el6                @ispsystem-beta
    ispmanager-pkg-quota.x86_64          5.33.0-1.el6                @ispsystem-beta
    ispmanager-pkg-roundcube.x86_64      5.33.0-1.el6                @ispsystem-beta
    ispmanager-pkg-sieve.x86_64          5.33.0-1.el6                @ispsystem-beta
    ispmanager-plugins.x86_64            5.33.0-1.el6                @ispsystem-beta

  6. #6
    Junior Member
    Регистрация
    22.07.2015
    Сообщений
    15

    По умолчанию

    Цитата Сообщение от usaafko Посмотреть сообщение

    странно. В возможностях apache установлен с mpm-itk?
    Да. Доступ в Панель разрешен, если это поможет...

    Судя по комментарию техподдержки хостинга, которая делала обновление, в процессе обновления возникли конфликты:
    Код:
    Error: ispmanager-pkg-httpd conflicts with ispmanager-pkg-httpd-itk-5.33.0-1.el6.x86_64
    Error: ispmanager-pkg-httpd-itk conflicts with ispmanager-pkg-httpd-5.33.0-1.el6.x86_64
    Error: ispmanager-pkg-pureftpd conflicts with ispmanager-pkg-proftpd-5.33.0-1.el6.x86_64
    Error: ispmanager-pkg-proftpd conflicts with ispmanager-pkg-pureftpd-5.33.0-1.el6.x86_64
    
    Обновили до 5.33.0-1
    coremanager.x86_64                   5.33.0-1.el6                @ispsystem-beta
    coremanager-pkg-bind.x86_64          5.33.0-1.el6                @ispsystem-beta
    coremanager-pkg-mysql.x86_64         5.33.0-1.el6                @ispsystem-beta
    coremanager-pkg-php.x86_64           5.33.0-1.el6                @ispsystem-beta
    ispmanager-lite.x86_64               5.33.0-1.el6                @ispsystem-beta
    ispmanager-lite-common.x86_64        5.33.0-1.el6                @ispsystem-beta
    ispmanager-pkg-awstats.x86_64        5.33.0-1.el6                @ispsystem-beta
    ispmanager-pkg-bind.x86_64           5.33.0-1.el6                @ispsystem-beta
    ispmanager-pkg-dovecot.x86_64        5.33.0-1.el6                @ispsystem-beta
    ispmanager-pkg-exim.x86_64           5.33.0-1.el6                @ispsystem-beta
    ispmanager-pkg-httpd-itk.x86_64      5.33.0-1.el6                @ispsystem-beta
    ispmanager-pkg-logrotate.x86_64      5.33.0-1.el6                @ispsystem-beta
    ispmanager-pkg-myadmin.x86_64        5.33.0-1.el6                @ispsystem-beta
    ispmanager-pkg-mysql.x86_64          5.33.0-1.el6                @ispsystem-beta
    ispmanager-pkg-nginx.x86_64          5.33.0-1.el6                @ispsystem-beta
    ispmanager-pkg-php.x86_64            5.33.0-1.el6                @ispsystem-beta
    ispmanager-pkg-phpext-ioncube.x86_64 5.33.0-1.el6                @ispsystem-beta
    ispmanager-pkg-phpfpm.x86_64         5.33.0-1.el6                @ispsystem-beta
    ispmanager-pkg-proftpd.x86_64        5.33.0-1.el6                @ispsystem-beta
    ispmanager-pkg-quota.x86_64          5.33.0-1.el6                @ispsystem-beta
    ispmanager-pkg-roundcube.x86_64      5.33.0-1.el6                @ispsystem-beta
    ispmanager-pkg-sieve.x86_64          5.33.0-1.el6                @ispsystem-beta
    ispmanager-plugins.x86_64            5.33.0-1.el6                @ispsystem-beta

  7. #7
    Senior Member
    Регистрация
    16.10.2010
    Сообщений
    1,652

    По умолчанию

    стокнулся с такой же проблеммой
    фикс сменить шаблон -> ок
    потом опять вызвать на редактирование юзера
    и вернуть шаблон
    после чего режими php вернулись обратно
    и теперь юзер может выбирать режимы php

  8. #8
    Junior Member
    Регистрация
    22.07.2015
    Сообщений
    15

    По умолчанию

    Цитата Сообщение от HappyAlex Посмотреть сообщение
    стокнулся с такой же проблеммой
    2 HappyAlex
    Видимо, это не мой случай: шаблоны не использую, для CGI выбор есть.
    Проблема в том, что пропал FastCGI (Apache) из настроек, в котором эта возможность выбора php так же была и использовалась...

  9. #9
    Junior Member
    Регистрация
    22.07.2015
    Сообщений
    15

    По умолчанию

    Цитата Сообщение от usaafko Посмотреть сообщение

    странно. В возможностях apache установлен с mpm-itk?
    Да. Доступ в Панель разрешен, если это поможет...

    Судя по комментарию техподдержки хостинга, которая делала обновление, в процессе обновления возникли конфликты:

    Error: ispmanager-pkg-httpd conflicts with ispmanager-pkg-httpd-itk-5.33.0-1.el6.x86_64
    Error: ispmanager-pkg-httpd-itk conflicts with ispmanager-pkg-httpd-5.33.0-1.el6.x86_64
    Error: ispmanager-pkg-pureftpd conflicts with ispmanager-pkg-proftpd-5.33.0-1.el6.x86_64
    Error: ispmanager-pkg-proftpd conflicts with ispmanager-pkg-pureftpd-5.33.0-1.el6.x86_64

    Обновили до 5.33.0-1
    coremanager.x86_64 5.33.0-1.el6 @ispsystem-beta
    coremanager-pkg-bind.x86_64 5.33.0-1.el6 @ispsystem-beta
    coremanager-pkg-mysql.x86_64 5.33.0-1.el6 @ispsystem-beta
    coremanager-pkg-php.x86_64 5.33.0-1.el6 @ispsystem-beta
    ispmanager-lite.x86_64 5.33.0-1.el6 @ispsystem-beta
    ispmanager-lite-common.x86_64 5.33.0-1.el6 @ispsystem-beta
    ispmanager-pkg-awstats.x86_64 5.33.0-1.el6 @ispsystem-beta
    ispmanager-pkg-bind.x86_64 5.33.0-1.el6 @ispsystem-beta
    ispmanager-pkg-dovecot.x86_64 5.33.0-1.el6 @ispsystem-beta
    ispmanager-pkg-exim.x86_64 5.33.0-1.el6 @ispsystem-beta
    ispmanager-pkg-httpd-itk.x86_64 5.33.0-1.el6 @ispsystem-beta
    ispmanager-pkg-logrotate.x86_64 5.33.0-1.el6 @ispsystem-beta
    ispmanager-pkg-myadmin.x86_64 5.33.0-1.el6 @ispsystem-beta
    ispmanager-pkg-mysql.x86_64 5.33.0-1.el6 @ispsystem-beta
    ispmanager-pkg-nginx.x86_64 5.33.0-1.el6 @ispsystem-beta
    ispmanager-pkg-php.x86_64 5.33.0-1.el6 @ispsystem-beta
    ispmanager-pkg-phpext-ioncube.x86_64 5.33.0-1.el6 @ispsystem-beta
    ispmanager-pkg-phpfpm.x86_64 5.33.0-1.el6 @ispsystem-beta
    ispmanager-pkg-proftpd.x86_64 5.33.0-1.el6 @ispsystem-beta
    ispmanager-pkg-quota.x86_64 5.33.0-1.el6 @ispsystem-beta
    ispmanager-pkg-roundcube.x86_64 5.33.0-1.el6 @ispsystem-beta
    ispmanager-pkg-sieve.x86_64 5.33.0-1.el6 @ispsystem-beta
    ispmanager-plugins.x86_64 5.33.0-1.el6 @ispsystem-beta

    P.S. К сожалению, не нашел как убрать под спойлер...

  10. #10
    Support team Аватар для usaafko
    Регистрация
    06.10.2013
    Сообщений
    2,384

    По умолчанию

    Цитата Сообщение от MaximWRC Посмотреть сообщение
    ispmanager-pkg-httpd-itk.x86_64 5.33.0-1.el6 @ispsystem-beta
    mpm-itk и mod_fcgid, к сожалению, не совместимы
    В "Возможностях" в разделе веб-сервера есть возможность переключить apache на mpm-prefork?

Метки этой темы

Ваши права

  • Вы не можете создавать новые темы
  • Вы не можете отвечать в темах
  • Вы не можете прикреплять вложения
  • Вы не можете редактировать свои сообщения
  •