Страница 4 из 7 ПерваяПервая ... 23456 ... ПоследняяПоследняя
Показано с 31 по 40 из 64

Тема: BILLmanager: модуль онлайн-чата доступен для установки

  1. #31
    Member Аватар для ukrop
    Регистрация
    15.10.2010
    Адрес
    Vladivostok
    Сообщений
    67

    По умолчанию

    Цитата Сообщение от Dasha Посмотреть сообщение
    ukrop, какая версия nodejs на сервере? Нужно, чтобы не выше 0.10.*. Откатите.
    Как узнать и как откатить? :-)

  2. #32
    Member Аватар для ukrop
    Регистрация
    15.10.2010
    Адрес
    Vladivostok
    Сообщений
    67

    По умолчанию

    Цитата Сообщение от Dasha Посмотреть сообщение
    ukrop, какая версия nodejs на сервере? Нужно, чтобы не выше 0.10.*. Откатите.
    node -v
    v6.9.1

  3. #33
    Support team Аватар для Dasha
    Регистрация
    03.11.2011
    Сообщений
    4,621

    По умолчанию

    rpm -qa | grep nodejs

  4. #34
    Member Аватар для ukrop
    Регистрация
    15.10.2010
    Адрес
    Vladivostok
    Сообщений
    67

    По умолчанию

    Цитата Сообщение от Dasha Посмотреть сообщение
    rpm -qa | grep nodejs
    rpm -qa | grep nodejs

    nodejs-ejs-1.0.0-1.el7.noarch
    nodejs-6.9.1-4.el7.x86_64
    coremanager-pkg-nodejs-5.86.0-2.el7.centos.x86_64

    А как откатить, не подскажете?

  5. #35
    Support team Аватар для Dasha
    Регистрация
    03.11.2011
    Сообщений
    4,621

    По умолчанию

    Как-то у меня получилось так откатить
    rpm -e --nodeps npm
    yum downgrade nodejs libuv

  6. #36
    Member Аватар для ukrop
    Регистрация
    15.10.2010
    Адрес
    Vladivostok
    Сообщений
    67

    По умолчанию

    Не получается. Ругается

    Error: Package: 1:nodejs-6.9.1-1.el7.x86_64 (epel)
    Requires: libuv.so.1()(64bit)
    Removing: 1:libuv-1.9.1-1.el7.x86_64 (@epel)
    libuv.so.1()(64bit)
    Downgraded By: 1:libuv-0.10.34-2.el7.x86_64 (epel)
    Not found

  7. #37
    Senior Member Аватар для Армаэль
    Регистрация
    22.03.2015
    Адрес
    Москва
    Сообщений
    287

    По умолчанию

    А кто сейчас занимается поддержкой по модулю: по моей проблеме что-то известно? Могу дать доступы, чтобы поковырять, может что-то выяснится эдакое неучтённое, если нет так нет - снесём модуль.

  8. #38
    Senior Member Аватар для VA
    Регистрация
    27.01.2007
    Сообщений
    1,346

    По умолчанию

    Dasha, а какие проблемы должны быть с новым nodejs? Обновление с 0.10.46 на 6.7.0 было еще в начале октября.

    Армаэль, проверьте хватает ли пользователю, под которым работает billchat, прав на запись в /opt/billchat/tmp/, /opt/billchat/tmp/sessions/

  9. #39
    Support team Аватар для Dasha
    Регистрация
    03.11.2011
    Сообщений
    4,621

    По умолчанию

    Из-за этой баги https://github.com/nodejs/node/issues/9015 чат сегфолтится.

  10. #40
    Senior Member Аватар для Армаэль
    Регистрация
    22.03.2015
    Адрес
    Москва
    Сообщений
    287

    По умолчанию

    VA, Да, хватает - "rwxr-xr-x". Он пишет файлы сессий в "/opt/billchat/tmp/sessions/" правда в "/opt/billchat/tmp/" не каких файлов не вижу, кроме каталога "sessions". И владелец каталогоа вроде "billchat [999]"... Сделал ради "на посмотреть" права "rwxrwxrwx", но нечего не поменялось.

    Клонировал диски с сервера, поставил свежие, так же сегодня ночью поставил свежий Debian 8, BILLmanager всё настроил вручную, чтобы исключить косяки с переносом, и всё равно тоже самое... Красотища.
    Последний раз редактировалось Армаэль; 30.01.2017 в 14:29.

Ваши права

  • Вы не можете создавать новые темы
  • Вы не можете отвечать в темах
  • Вы не можете прикреплять вложения
  • Вы не можете редактировать свои сообщения
  •