Показано с 1 по 7 из 7

Тема: Ошибка при каждом обновлении панели ISP Manager 5

  1. #1
    Junior Member
    Регистрация
    03.03.2008
    Сообщений
    17

    По умолчанию Ошибка при каждом обновлении панели ISP Manager 5

    Здравствуйте.
    При каждом обновлении панели получаю одну и ту же ошибку:
    Код:
    ...
    dpkg: зависимости пакетов не позволяют настроить пакет ispmanager-pkg-phpfpm:
     ispmanager-pkg-phpfpm зависит от ispmanager-pkg-nginx, однако:
      Пакет ispmanager-pkg-nginx пока не настроен.
    
    dpkg: ошибка при обработке параметра ispmanager-pkg-phpfpm (--configure):
     проблемы зависимостей — оставляем не настроенным
    При обработке следующих пакетов произошли ошибки:
     ispmanager-pkg-phpfpm
    E: Sub-process /usr/bin/dpkg returned an error code (1)
    Проблема решается с помощью:
    Код:
    apt-get -f install
    Выбрана бета ветка.
    Код:
    # cat /usr/local/mgr5/etc/repo.version
    beta
    Debian Wheezy 7.11

    Есть еще один точно такой же сервер, там все те же обновления до тех же версий проходят без проблем. Куда копать, какие логи смотреть?

  2. #2
    Support team Аватар для Sedna
    Регистрация
    16.05.2014
    Сообщений
    1,557

    По умолчанию

    Подробности установки и обновлений пишутся в /usr/local/mgr5/var/pkg.log
    Grammar Nazi

  3. #3
    Junior Member
    Регистрация
    27.08.2009
    Сообщений
    28

    По умолчанию

    Цитата Сообщение от Hatifnatt Посмотреть сообщение
    Здравствуйте.
    При каждом обновлении панели получаю одну и ту же ошибку:
    Точно такая же ошибка! Один к одному. И тоже Debian 7.11

  4. #4
    Member
    Регистрация
    02.08.2013
    Сообщений
    78

    По умолчанию

    у меня debian 8, bussness beta, тоже после каждого обновления панели приходиться делать
    apt-get -f install
    apt-get dist-upgrade, доставляя приложения, которые каким-то образом пропадают.

    что делать с этой ошибкой ?
    Код:
     apt-get dist-upgrade
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    Calculating upgrade... Done
    The following packages will be upgraded:
      mysql-server-5.5
    1 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
    Need to get 1,769 kB of archives.
    After this operation, 1,024 B disk space will be freed.
    Do you want to continue? [Y/n] y
    Get:1 http://security.debian.org/ jessie/updates/main mysql-server-5.5 amd64 5.5.50-0+deb8u1 [1,769 kB]
    Fetched 1,769 kB in 0s (15.6 MB/s)
    Preconfiguring packages ...
    (Reading database ... 58915 files and directories currently installed.)
    Preparing to unpack .../mysql-server-5.5_5.5.50-0+deb8u1_amd64.deb ...
    dpkg: error processing archive /var/cache/apt/archives/mysql-server-5.5_5.5.50-0+deb8u1_amd64.deb (--unpack):
     subprocess new pre-installation script returned error exit status 1
    Errors were encountered while processing:
     /var/cache/apt/archives/mysql-server-5.5_5.5.50-0+deb8u1_amd64.deb
    E: Sub-process /usr/bin/dpkg returned an error code (1)
    NDB Cluster seems to be in use MySQL-5.5 no longer provides NDB Cluster support. Please migrate to the new mysql-cluster-server package and remove all lines starting with "ndb" from all config files below
    /etc/mysql/.
    Последний раз редактировалось kreonike; 08.08.2016 в 15:35.

  5. #5
    Support team Аватар для Fly
    Регистрация
    14.08.2010
    Сообщений
    4,764

    По умолчанию

    Pre install скрипт пакета mysql-server вернул ошибку:

    subprocess new pre-installation script returned error exit status 1

    С помощью команды dpkg-deb -e <путь до пакета> <путь куда развернуть> можно развернуть пакет и посмотреть/запустить pre install скрипт и будет понятно что с ним не так.

  6. #6
    Member
    Регистрация
    02.08.2013
    Сообщений
    78

    По умолчанию

    так он мне вот это и пишет:
    NDB Cluster seems to be in use MySQL-5.5 no longer provides NDB Cluster support. Please migrate to the new mysql-cluster-server package and remove all lines starting with "ndb" from all config files below
    /etc/mysql/.

    если сделаю, что он просит, панель будет корректно работать ?

  7. #7
    Junior Member
    Регистрация
    03.03.2008
    Сообщений
    17

    По умолчанию

    Цитата Сообщение от Sedna Посмотреть сообщение
    Подробности установки и обновлений пишутся в /usr/local/mgr5/var/pkg.log
    Обновление запускаю из консоли, не из панели, поэтому в указанном логе ничего нет. Собственно вся полезная информация присутствует в изначальном сообщении - конфликт зависимостей. Почему он возникает на одном сервере и не возникает на другом, вот в чем вопрос.

Метки этой темы

Ваши права

  • Вы не можете создавать новые темы
  • Вы не можете отвечать в темах
  • Вы не можете прикреплять вложения
  • Вы не можете редактировать свои сообщения
  •