Показано с 1 по 3 из 3

Тема: Расширения php 7 не запускаются

  1. #1
    Junior Member
    Регистрация
    11.04.2016
    Сообщений
    11

    По умолчанию Расширения php 7 не запускаются

    Здравствуйте уважаемые форумчане. Подскажите пожалуйста, в чём может крыться проблема. Имеем ubuntu 16.04 с установленной ispmanager lite. На PHP 7.0.13 не могу запустить несколько расширений: gd, tidy, mcrypt. Остальные не мучил, не нужны пока. В чём может быть проблема.
    Установка панели была на чистую ОС в режиме минимальной, устанавливал пых из панели. Вообще раньше подобное не требовало дополнительных телодвижений. Поисковики молчат на этот счёт.
    P.S. пробовал удалять расширение и устанавливать руками, панель не видит такое расширение.

  2. #2
    Senior Member
    Регистрация
    06.03.2016
    Адрес
    UA
    Сообщений
    137

    По умолчанию

    пых7 как native? в каком режиме запускаете? (fpm, mod apache/apacge cgi/fcgi)?
    версия панели какая?

  3. #3
    Junior Member
    Регистрация
    11.04.2016
    Сообщений
    11

    По умолчанию

    php как нативная, режим php-fpm, панель последняя
    Вываливается ошибка
    [17-Jan-2017 12:37:43 Asia/Krasnoyarsk] PHP Warning: PHP Startup: Unable to load dynamic library '/usr/lib/php/20151012/' - /usr/lib/php/20151012/: cannot read file data: Is a directory in Unknown on line 0

    P.S. причём потестил, другие расширения отключаются и включаются нормально.
    Последний раз редактировалось dotWizard; 17.01.2017 в 13:43.

Ваши права

  • Вы не можете создавать новые темы
  • Вы не можете отвечать в темах
  • Вы не можете прикреплять вложения
  • Вы не можете редактировать свои сообщения
  •