Показано с 1 по 8 из 8

Тема: Перестал работать модуль Let's Encrypt

  1. #1
    Junior Member
    Регистрация
    22.01.2017
    Сообщений
    7

    По умолчанию

    Здравствуйте.

    Ошибки при получении сертификата Let's Encrypt:
    Код:
    Запрос на выдачу нового сертифика завершился неудачей
    return code:429
    Details:Error creating new cert :: Too many certificates already issued for exact set of domains: site.com,www.site.com
    Последний раз редактировалось Lucard; 16.07.2019 в 16:30.

  2. #2

    По умолчанию

    У меня такая же ерунда.
    Я для одного главного и 3-х поддоменов сделал сертификаты - дальше перестал выдавать. Видимо у Let's Encrypt есть лимит.

  3. #3
    Support team Аватар для Dasha
    Регистрация
    03.11.2011
    Сообщений
    4,621

    По умолчанию

    Есть предположение, что панель пытается перевыпустить сертификат на удаленный либо заново пересозданный домен. Попробуйте отключить у домена SSSl. Удалить domain.com_le1 из панели. Затем перезапустить выпуск сертификата.

  4. #4
    Support team Аватар для Dasha
    Регистрация
    03.11.2011
    Сообщений
    4,621

    По умолчанию

    В /usr/local/mgr5/var/ispmgr.log пишется.

  5. #5
    Junior Member
    Регистрация
    16.10.2018
    Сообщений
    1

    По умолчанию

    Цитата Сообщение от Lucard Посмотреть сообщение
    Уважаемая, поддержка. Не хочу плодить темы, ошибка не решилась, но после последних обновлений сертификат перестал получаться с новой ошибкой:
    Код:
    В процессе получения Let's Encrypt сертификата domain.com_le1 произошла ошибка: Type: 'missed' Object: 'unknown' Value: 'domain.com'
    В какую сторону смотреть?
    Здравствуйте! Как у Вас получилось исправить ошибку "В процессе получения Let's Encrypt сертификата domain.com_le1 произошла ошибка: Type: 'missed' Object: 'unknown' Value: 'domain.com'"

  6. #6
    Support team Аватар для Dasha
    Регистрация
    03.11.2011
    Сообщений
    4,621

    По умолчанию

    Напишите запрос в техническую поддержку - посмотрим. Скорее всего у вас ISPmanager Business, и домена не хватает в какой-нибудь базе.

  7. #7
    Junior Member
    Регистрация
    09.03.2015
    Сообщений
    3

    По умолчанию

    Добрый день.

    Схожая проблема, ISPmanager Lite 5.221.2
    После обновления 5.204.0 (2019-06-11) перестал работать выпуск сертификатов через модуль Let's Encrypt. Т.к. особой надобности в нём на тот момент не было, попробовали только переустановить модуль. Это не помогло. Сейчас необходимость появилась, си стема автоматом обновлялась до последней - но проблема не решилась.

    Если тестировать выпуск сертификата:

    При попытке выпустить сертификат в настройках www-домена ( галкой "Защищенное соединение (SSL)" и выбрав "Новый Let's Encrypt сертификат ), - панель выдаёт красную ошибку на всплывающем облаке: "SSL-сертификаты со значением 'domain.name_le1' отсутствует" и не позволяет сохранить новые настройки www-домена.

    в этот момент в логе /usr/local/mgr5/var/ispmgr.log - всплывают:

    по фильтру WARNING:
    Nov 1 08:47:36 [8428:402] core_decoration WARNING Duplicate value 'on' for input '/doc/show_cache'
    Nov 1 08:47:36 [8428:402] libmgr WARNING Error in SafeJob::Rollback: Type: 'cert_used'
    Nov 1 08:47:36 [8428:402] core WARNING 0x7f04b00051d0 Restart request
    Nov 1 08:47:36 [8428:403] core_decoration WARNING Duplicate value 'on' for input '/doc/show_cache'
    Nov 1 08:47:36 [8428:403] core_decoration WARNING Value '' for 'analyzer_lang' select is missed in slist and will be ignored

    по фильтру Error:
    Nov 1 08:47:36 [8428:402] libmgr ERROR Error: Type: 'missed' Object: 'sslcert' Value: 'domain.name_le1'
    Nov 1 08:47:36 [8428:402] libmgr ERROR Error: Type: 'cert_used'
    Nov 1 08:47:36 [8428:402] libmgr WARNING Error in SafeJob::Rollback: Type: 'cert_used'

    При попытке выпустить сертификат через меню SSL-сертификаты -> Let's Encrypt
    ещё при выборе пользователя и нужного домена, в лог начинают сыпаться WARNING:
    Nov 1 08:59:38 [8428:508] conn WARNING Ignore empty 'elid'
    Nov 1 08:59:39 [8428:508] core_decoration WARNING Duplicate value 'on' for input '/doc/show_cache'
    Nov 1 08:59:39 [8428:508] core_decoration WARNING Value 'domain.name' for 'domain_name' select is missed in slist and will be ignored
    Nov 1 08:59:39 [8428:508] core_decoration WARNING Duplicate value 'on' for input '/doc/show_cache'
    Nov 1 08:59:39 [8428:511] conn WARNING Ignore empty 'elid'
    Nov 1 08:59:39 [8428:511] core_decoration WARNING Duplicate value 'on' for input '/doc/show_cache'
    Nov 1 08:59:39 [8428:511] core_decoration WARNING Value 'domain.name' for 'domain_name' select is missed in slist and will be ignored

    Выбрав пользователя и домен и нажав ОК ( не важно - ставить галки dns или wildcard ), - панель выдаёт красную ошибку на всплывающем облаке: "Поле 'SSL-сертификат' имеет недопустимое значение." и не позволяет завершить операцию.

    Если снять галку "Включить SSL-сертификат", - то окно закрывается по кнопке "Ок";
    В логе появляются Warning
    Nov 1 09:04:53 [8428:541] conn WARNING Ignore empty 'elid'
    Nov 1 09:04:53 [8428:541] core_decoration WARNING Duplicate value 'on' for input '/doc/show_cache'
    Nov 1 09:04:53 [8428:541] core_decoration WARNING Value 'domain.name' for 'domain_name' select is missed in slist and will be ignored

    а по фильтру Error:
    Nov 1 09:02:45 [8428:530] libmgr ERROR Error: Type: 'value' Object: 'ssl_cert' Value: 'domain.name_le1'
    Nov 1 09:06:18 [8428:558] libmgr ERROR Error: Type: 'missed' Object: 'sslcert' Value: 'domain.name_le1'

    В самой панели появляется ошибка: "Параметры уведомления - Let's Encrypt сертификат"
    В процессе получения Let's Encrypt сертификата domain.name_le1 произошла ошибка: Type: 'missed' Object: 'sslcert' Value: 'domain.name_le1'

    При этом, в access логе домена видно, что сам Let's Encrypt начал стучаться к домену:
    18.197.227.110 - - [01/Nov/2019:09:06:09 +0300] "GET /.well-known/acme-challenge/NYVPdvNGNua08u1c4XvLG_g4XfdJTSoJjhi7lrElzrg HTTP/1.1" 200 87 "-" "Mozilla/5.0 (compatible; Let's Encrypt validation server; +https://www.letsencrypt.org)"
    66.133.109.36 - - [01/Nov/2019:09:06:10 +0300] "GET /.well-known/acme-challenge/NYVPdvNGNua08u1c4XvLG_g4XfdJTSoJjhi7lrElzrg HTTP/1.1" 200 87 "-" "Mozilla/5.0 (compatible; Let's Encrypt validation server; +https://www.letsencrypt.org)"
    34.222.229.130 - - [01/Nov/2019:09:06:10 +0300] "GET /.well-known/acme-challenge/NYVPdvNGNua08u1c4XvLG_g4XfdJTSoJjhi7lrElzrg HTTP/1.1" 200 87 "-" "Mozilla/5.0 (compatible; Let's Encrypt validation server; +https://www.letsencrypt.org)"
    18.197.227.110 - - [01/Nov/2019:09:06:13 +0300] "GET /.well-known/acme-challenge/YNN6UGMlm643SeSiTMznPWxQZ4bv5OqiF7wBPoE0dpw HTTP/1.1" 200 87 "-" "Mozilla/5.0 (compatible; Let's Encrypt validation server; +https://www.letsencrypt.org)"
    3.14.255.131 - - [01/Nov/2019:09:06:13 +0300] "GET /.well-known/acme-challenge/YNN6UGMlm643SeSiTMznPWxQZ4bv5OqiF7wBPoE0dpw HTTP/1.1" 200 87 "-" "Mozilla/5.0 (compatible; Let's Encrypt validation server; +https://www.letsencrypt.org)"
    64.78.149.164 - - [01/Nov/2019:09:06:13 +0300] "GET /.well-known/acme-challenge/YNN6UGMlm643SeSiTMznPWxQZ4bv5OqiF7wBPoE0dpw HTTP/1.1" 200 87 "-" "Mozilla/5.0 (compatible; Let's Encrypt validation server; +https://www.letsencrypt.org)"

    Но сам сертификат в списке не создаётся.

    Удаление модуля и его повторная его установка не помогает. Куда копать - тоже не понятно.

  8. #8
    Junior Member
    Регистрация
    24.02.2020
    Сообщений
    2

    По умолчанию

    Аналогично интересует решение этой проблемы.

    По наблюдениям ошибка идет после подмены шаблонов nginx. При этом, даже была когда в файлах ничего не менял, просто переместил шаблоны из default папки на уровень выше и в nginx-vhosts.conf поменял путь до nginx-vhosts-ssl.conf.

Ваши права

  • Вы не можете создавать новые темы
  • Вы не можете отвечать в темах
  • Вы не можете прикреплять вложения
  • Вы не можете редактировать свои сообщения
  •