Показано с 1 по 7 из 7

Тема: Не работает Proftpd

  1. #1
    Member Аватар для MyHost.KG
    Регистрация
    30.08.2014
    Адрес
    Kyrgyzstan, Bishskek
    Сообщений
    39

    Exclamation Не работает Proftpd

    Подскажите, можно ли решить проблему без переустановки proftpd?
    И если нет, то как безболезненно переставить. Заранее спасибо!

    Код:
    [ ok ] Stopping ftp server: proftpd.
    [....] Starting ftp server: proftpd *** proftpd[27998]: mod_tls/2.4.3: compiled using OpenSSL version 'OpenSSL 1.0.1e 11 Feb 2013' headers, but linked to OpenSSL version 'OpenSSL 1.0.1t  3 May 2016' library
    . ok
    Панель: ISPmanager Business 5.64.2
    ОС: Debian 7
    Последний раз редактировалось MyHost.KG; 21.02.2017 в 09:04.

  2. #2
    Member Аватар для MyHost.KG
    Регистрация
    30.08.2014
    Адрес
    Kyrgyzstan, Bishskek
    Сообщений
    39

    По умолчанию

    также с самой панели не удается создать ftp пользователя

    Код:
    Не удалось найти функцию 'ftp.user.edit'. Возможно, управляющий модуль не загружен.
    в логе

    Код:
    libmgr ERROR Error: Type: 'missed' Object: 'function' Value: 'ftp.user.edit'

  3. #3
    Support team Аватар для Fly
    Регистрация
    14.08.2010
    Сообщений
    4,764

    По умолчанию

    Здравствуйте,

    Возможно, надо просто обновить proftpd. Изучите вопрос какая версия OpenSSL нужна новой версии proftpd.

    Не удалось найти функцию 'ftp.user.edit'. Возможно, управляющий модуль не загружен.
    Это следствие первой проблемы.

  4. #4
    Member Аватар для MyHost.KG
    Регистрация
    30.08.2014
    Адрес
    Kyrgyzstan, Bishskek
    Сообщений
    39

    По умолчанию

    Цитата Сообщение от Fly Посмотреть сообщение
    Здравствуйте,
    Возможно, надо просто обновить proftpd.
    там 3 пакета, ispmanager-pkg-proftpd, proftpd-basic, proftpd-mod-vroot, если поставить новее proftpd-basic будет ли он корректно работать с остальными?


    Цитата Сообщение от Fly Посмотреть сообщение
    Изучите вопрос какая версия OpenSSL нужна новой версии proftpd.
    ну дело в том что mod_tls был собран с OpenSSL 1.0.1e, а в системе сейчас стоит OpenSSL 1.0.1t

  5. #5
    Member Аватар для MyHost.KG
    Регистрация
    30.08.2014
    Адрес
    Kyrgyzstan, Bishskek
    Сообщений
    39

    По умолчанию

    всё еще актуально.

  6. #6
    Member Аватар для MyHost.KG
    Регистрация
    30.08.2014
    Адрес
    Kyrgyzstan, Bishskek
    Сообщений
    39

    По умолчанию

    вопрос решен, можно удалить тему или перенести в архив.

  7. #7
    Support team Аватар для Dasha
    Регистрация
    03.11.2011
    Сообщений
    4,621

    По умолчанию

    Напишите, пожалуйста, как решили проблему. Возможно, кому-нибудь пригодится.

Метки этой темы

Ваши права

  • Вы не можете создавать новые темы
  • Вы не можете отвечать в темах
  • Вы не можете прикреплять вложения
  • Вы не можете редактировать свои сообщения
  •