Страница 6 из 8 ПерваяПервая ... 45678 ПоследняяПоследняя
Показано с 51 по 60 из 76

Тема: Let's Encrypt ошибка при получении сертификата (return code:400)

  1. #51
    Member Аватар для Aleksandr.
    Регистрация
    04.05.2016
    Сообщений
    71

    По умолчанию

    Цитата Сообщение от Angelys Посмотреть сообщение
    Lazek, вы понимаете что Ispsystem нарушили лицензию GNU GPL acme.sh ? Нельзя встраивать бесплатное ПО в коммерческий продукт. Вы фактически сейчас продаете правку к бесплатному скрипту acme.sh и SSL сертификат Let's Encrypt, другие обновления вашего ПО на данный момент мне не нужны, как будут нужны я обновлюсь.

    Прошу открыть код библиотеки которая связана с acme.sh и Let's Encrypt для обновления соглашения https://letsencrypt.org/documents/LE...er-15-2017.pdf.

    Спасибо.
    странное молчание со стороны isp...

  2. #52
    Senior Member Аватар для Lazek
    Регистрация
    04.06.2008
    Сообщений
    922

    По умолчанию

    Цитата Сообщение от Aleksandr. Посмотреть сообщение
    странное молчание со стороны isp...
    Ответ доступен на каждой страничке форума, пожалуйста:
    Все вопросы, размещенные на данном форуме, будут рассмотрены и изучены нашими специалистам, однако компания ISPsystem не принимает на себя персональных обязательств перед Пользователем по предоставлению ему консультаций по задаваемым на форуме вопросам. О получении гарантированной и оперативной поддержки читайте на нашем сайте

  3. #53
    Member Аватар для Aleksandr.
    Регистрация
    04.05.2016
    Сообщений
    71

    По умолчанию

    Цитата Сообщение от Lazek Посмотреть сообщение
    Ответ доступен на каждой страничке форума, пожалуйста:
    бла бла бла

    разумеется , посылать каждый умеет, а вот не понятно где ответ, за нарушение лицензии. не красиво бесплатные решения закрывать платным кодом.

  4. #54
    Senior Member Аватар для Lazek
    Регистрация
    04.06.2008
    Сообщений
    922

    По умолчанию

    Цитата Сообщение от Aleksandr. Посмотреть сообщение
    бла бла бла

    разумеется , посылать каждый умеет, а вот не понятно где ответ, за нарушение лицензии. не красиво бесплатные решения закрывать платным кодом.
    Ответ уже был выше, соответствующая ошибка / пожелание - было зарегистрировано и ссылка на него имеется в текущей теме, возможно, в дальнейшем будут внесены какие-либо изменения, моментальных правок ожидать не стоит.

  5. #55
    Head of Product Management
    Регистрация
    16.02.2016
    Сообщений
    41

    По умолчанию

    В целях определения возможности совместного распространения коммерческого закрытого программного обеспечения и программного обеспечения по лицензии GPL v.3 надлежит обратиться к последнему абзацу раздела 5 GPL v.3 «Conveying Modified Source Versions»: «A compilation of a covered work with other separate and independent works, which are not by their nature extensions of the covered work, and which are not combined with it such as to form a larger program<...> Inclusion of a covered work in an aggregate does not cause this License to apply to the other parts of the aggregate.»

    Указанное положение не раскрывает характера взаимодействия ПО и критериев формирования «combined» и «larger» программ, однако подход к толкованию раскрыт в официальном FAQ, в частности (с применением аналогии): https://www.gnu.org/licenses/gpl-faq.en.html#GPLPlugins

    С учетом указанного, принимая во внимание характер взаимодействия с «acme.sh», положения GPL v. 3 соблюдаются в полном объеме.

    Также еще раз сообщаем, что невозможность выпуска сертификата на web-домен не связано с acme.sh, а проблема нашей реализации протокола ACME, исправление которого уже есть в последних бета и стейбл версиях.

  6. #56
    Head of Product Management
    Регистрация
    16.02.2016
    Сообщений
    41

    По умолчанию

    Цитата Сообщение от Yoh Посмотреть сообщение
    Такое бывает как при продлении, так и при создании нового сертификата. Лечится действительно удалением заявки и созданием новой на сертификат. Но это крайне неудобно.
    Ошибки при продлении действительно могут быть.
    В случае ошибок при создании нового сертификата обратитесь в службу поддержки, при тестировании данной функциональности подобная ошибка не воспроизводится.
    Мы так же как и вы заинтересованы в исправлении этого неправильного поведения интеграции.

  7. #57
    Junior Member
    Регистрация
    06.02.2018
    Сообщений
    4

    По умолчанию

    Столкнулся с этой проблемой. Перепробовал все варианты, предложенные уважаемыми пользователями: отключал SSL, удалял сертификаты и даже удалял и опять устанавливал модуль Lets Encript. Обновил панель ISP. При каждом действии перезагружал сервер.
    ISP.jpg
    Установлено автообновление всего ПО. Результат тот же - return code:400

    Details:Provided agreement URL [https://letsencrypt.org/documents/LE...st-1-2016.pdf] does not match current agreement URL [https://letsencrypt.org/documents/LE...r-15-2017.pdf]
    И что же дальше делать?
    Последний раз редактировалось ludent; 06.02.2018 в 21:53.

  8. #58
    Senior Member Аватар для Lazek
    Регистрация
    04.06.2008
    Сообщений
    922

    По умолчанию

    Здравствуйте,

    У Вас установлена не последняя версия панели управления, попробуйте по SSH обновить все ПО вручную, скорее всего возникнут некие ошибки, сделать можно по средствам команд:
    yum clean all
    yum update

  9. #59
    Junior Member
    Регистрация
    06.02.2018
    Сообщений
    4

    По умолчанию

    Цитата Сообщение от Lazek Посмотреть сообщение
    Здравствуйте,

    У Вас установлена не последняя версия панели управления, попробуйте по SSH обновить все ПО вручную, скорее всего возникнут некие ошибки, сделать можно по средствам команд:
    yum clean all
    yum update
    Попробовал через Putty. Все осталось по-прежнему. После обновления по SSH через Putty сделал reboot, результата нет. Ниже скрины. Прошу подсказать, что можно еще сделать.
    2018-02-07_09-36_PuTTY (inactive.jpg2018-02-07_09-37.jpg2018-02-07_09-40.jpg
    Последний раз редактировалось ludent; 07.02.2018 в 14:43.

  10. #60

    По умолчанию

    У вас стоит PHP и phpmyadmin из неподдерживаемого репозитория(remi). Он блокирует обновление, так как вызывает конфликт пакетов. Отключите remi

Ваши права

  • Вы не можете создавать новые темы
  • Вы не можете отвечать в темах
  • Вы не можете прикреплять вложения
  • Вы не можете редактировать свои сообщения
  •