Показано с 1 по 3 из 3

Тема: не работает прокси /mancgi

  1. #1
    Member
    Регистрация
    08.02.2017
    Сообщений
    34

    По умолчанию не работает прокси /mancgi

    Здравствуйте.

    Подскажите как правильно настроить прокси и какие порты открыть? Нынешний конфиг nginx:
    Код:
      server {
      listen 443 ssl http2;
    
        ssl_certificate /etc/.../cert.pem;
        ssl_certificate_key /etc/.../privkey.pem;
    
    	server_name billing.domain.tld;
    
           set $mgr_proxy "https://x.x.x.x:1550";         
             
           location / { 		
                    proxy_pass $mgr_proxy; 		
                    proxy_redirect $mgr_proxy /; 		
                    proxy_set_header Host $host:$server_port; 		
                    proxy_set_header X-Forwarded-For $remote_addr; 		
                    proxy_set_header X-Forwarded-Proto $scheme; 		
                    proxy_set_header X-Real-IP $remote_addr;                
                    proxy_set_header X-Forwarded-Secret mysecret;  		
                    chunked_transfer_encoding off; 
     	}
    
     	location ^~ /mancgi/ {
    	        proxy_pass $mgr_proxy;
    	        proxy_redirect $mgr_proxy /;
    	        proxy_set_header Host $host:$server_port;
    	        proxy_set_header X-Forwarded-For $remote_addr; 
                    proxy_set_header X-Forwarded-Proto $scheme;
    	        proxy_set_header X-Real-IP $remote_addr;
    	        proxy_set_header X-Forwarded-Secret mmysecret;
    	        chunked_transfer_encoding off;
    	}
    }
    nginx и сам billmanager находятся на разных серверах. К серверу с billmanager проброшен порт 1550. Сама панель отлично работает, но доступа к /mancgi нет.
    проброс 80,443 портов не помогает.

    При доступе к "billing.domain.tld/mancgi/test.php" nginx говорит 504 (gateway time-out)
    При попытке доступа в локальной сети "http://10.0.0.50:1550/mancgi/test.php" - тоже 504

    Подскажите, как это можно исправить?
    Последний раз редактировалось Aleksej; 30.07.2018 в 20:24. Причина: доступ с локальной сети

  2. #2
    BILLmanager team
    Регистрация
    17.09.2010
    Сообщений
    8,555

    По умолчанию

    Здравствуйте, попробуйте вызывать стандартный cgi BILLmanager. Например billing.domain.tld/mancgi/counter
    Так же попробуйте конфигурацию без http2

  3. #3
    Member
    Регистрация
    08.02.2017
    Сообщений
    34

    По умолчанию

    Приношу извинения за недосмотр.

    С непонятно какого перепугу скрипт стал ругаться на создание даты
    Код HTML:
    Fatal error: Uncaught exception 'Exception' with message 'DateTime::__construct(): It is not safe to rely on the system's timezone settings. You are *required* to use the date.timezone setting or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected the timezone 'UTC' for now, but please set date.timezone to select your timezone.' in /usr/local/mgr5/cgi/test.php:44
    Stack trace:
    #0 /usr/local/mgr5/cgi/test.php(44): DateTime->__construct('2018-07-30 14:1...')
    #1 {main}
    собственно код:
    PHP код:
    $invdate=new DateTime($payinfo["doc"]["payment"][0]["createdate"]["$"]); 
    а отображение ошибок было выключено...

    на данный момент я кое-как заставил его "кушать" дату через
    PHP код:
    $dy=substr($payinfo["doc"]["payment"][0]["createdate"]["$"],0,10);

    $invdate=date_create_from_format('Y-m-d',$dy); 
    тут хоть и та самая ругня но уже с Эwarning" а не "Fatal" ))

Ваши права

  • Вы не можете создавать новые темы
  • Вы не можете отвечать в темах
  • Вы не можете прикреплять вложения
  • Вы не можете редактировать свои сообщения
  •