Показано с 1 по 9 из 9

Тема: Обновление nginx

  1. #1
    Senior Member Аватар для xsacha
    Регистрация
    29.06.2015
    Сообщений
    243

    Question Обновление nginx

    Подскажите пытаюсь обновить nginx и он пишет такое:
    rpm -Uvh /root/rpmbuild/RPMS/x86_64/nginx-1.15.3-1.el7_4.ngx.x86_64.rpm
    Подготовка... ################################# [100%]
    пакет nginx-2:1.14.0-1.el7_4.ngx.x86_64 (который новее, чем nginx-1:1.15.3-1.el7_4.ngx.x86_64) уже установлен
    Как можно принудительно обновить старую версию на более новую ?
    Вопрос решил так, выполнил это
    yum downgrade /root/rpmbuild/RPMS/x86_64/nginx-1.14.0-1.el7_4.ngx.x86_64.rpm
    А потом обновление и все прошло успешно.
    Последний раз редактировалось xsacha; 30.08.2018 в 17:24.
    В ISP Manager я новичек, но веб панелька мне однозначно нравится.

  2. #2
    Senior Member Аватар для xsacha
    Регистрация
    29.06.2015
    Сообщений
    243

    По умолчанию

    Подскажите обновление из вашего репозитория потом ставится по верх более новой версии, как решить данную проблему ?
    --> Проверка сценария
    ---> Пакет nginx.x86_64 1:1.15.3-1.el7_4.ngx помечен для обновления
    ---> Пакет nginx.x86_64 2:1.14.0-1.el7_4.ngx помечен как обновление
    --> Проверка зависимостей окончена

    Зависимости определены

    ================================================== ==============================
    Package Архитектура Версия Репозиторий Размер
    ================================================== ==============================
    Обновление:
    nginx x86_64 2:1.14.0-1.el7_4.ngx ispsystem-base 750 k

    Итого за операцию
    ================================================== ==============================
    Обновить 1 пакет
    Последний раз редактировалось xsacha; 31.08.2018 в 15:14.
    В ISP Manager я новичек, но веб панелька мне однозначно нравится.

  3. #3
    Senior Member Аватар для Виктор
    Регистрация
    27.08.2008
    Адрес
    MGNHost.ru
    Сообщений
    3,225

    По умолчанию

    Цитата Сообщение от xsacha Посмотреть сообщение
    Подскажите обновление из вашего репозитория потом ставится по верх более новой версии, как решить данную проблему ?
    В настройках репозитория прописать в качестве исключения nginx.

  4. #4
    Senior Member Аватар для xsacha
    Регистрация
    29.06.2015
    Сообщений
    243

    По умолчанию

    Цитата Сообщение от Виктор Посмотреть сообщение
    В настройках репозитория прописать в качестве исключения nginx.
    Можно написать пример как это делается ?
    Все понял
    exclude=nginx
    Последний раз редактировалось xsacha; 31.08.2018 в 15:39.
    В ISP Manager я новичек, но веб панелька мне однозначно нравится.

  5. #5
    Senior Member
    Регистрация
    09.04.2013
    Адрес
    Москва
    Сообщений
    2,001

    По умолчанию

    ---> Пакет nginx.x86_64 1:1.15.3-1.el7_4.ngx помечен для обновления
    ---> Пакет nginx.x86_64 2:1.14.0-1.el7_4.ngx помечен как обновление

  6. #6
    Senior Member Аватар для Виктор
    Регистрация
    27.08.2008
    Адрес
    MGNHost.ru
    Сообщений
    3,225

    По умолчанию

    Цитата Сообщение от Mobiaaa Посмотреть сообщение
    ---> Пакет nginx.x86_64 1:1.15.3-1.el7_4.ngx помечен для обновления
    ---> Пакет nginx.x86_64 2:1.14.0-1.el7_4.ngx помечен как обновление
    У него просто версия эпохи выше, поэтому система и считает его более новой версией.

  7. #7
    Senior Member Аватар для xsacha
    Регистрация
    29.06.2015
    Сообщений
    243

    По умолчанию

    Цитата Сообщение от Виктор Посмотреть сообщение
    У него просто версия эпохи выше, поэтому система и считает его более новой версией.
    Верно, но такой nginx пришел из репозитория ISP если бы там была 1 тогда было бы все нормально и не надо делать исключение. Вопрос ТП вы решите данный вопрос или так и жить с исключением ?
    В ISP Manager я новичек, но веб панелька мне однозначно нравится.

  8. #8
    Junior Member
    Регистрация
    12.05.2018
    Сообщений
    14

    По умолчанию

    Не будут они этот вопрос решать.
    Это сделано умышленно, что бы вы не могли обновить nginx штатными средствами.

  9. #9
    Senior Member Аватар для Виктор
    Регистрация
    27.08.2008
    Адрес
    MGNHost.ru
    Сообщений
    3,225

    По умолчанию

    Цитата Сообщение от xsacha Посмотреть сообщение
    Верно, но такой nginx пришел из репозитория ISP если бы там была 1 тогда было бы все нормально и не надо делать исключение. Вопрос ТП вы решите данный вопрос или так и жить с исключением ?
    Хоть я и не отношусь ни как к ISPsystem, но отвечу на Ваш вопрос, так и жить с исключением.
    Если они изменят версию эпохи на меньшую, то у всех, у кого сейчас установлен уже их nginx, просто перестанет обновляться на новые версии.

Ваши права

  • Вы не можете создавать новые темы
  • Вы не можете отвечать в темах
  • Вы не можете прикреплять вложения
  • Вы не можете редактировать свои сообщения
  •