Показано с 1 по 2 из 2

Тема: Установка redis на альтернативные версии php

  1. #1
    Junior Member
    Регистрация
    17.04.2013
    Сообщений
    2

    По умолчанию Установка redis на альтернативные версии php

    У меня панель isp 5
    Centos 7
    Через панель установил несколько версий php от 5.4 до 7.1
    Установил модуль redis
    Все вроде настроил, но он работает только для версии 5,4
    Как мне настроить редис для других версий php
    Я очень плохо разбираюсь в настройках.
    Все что устанавливаю, только по инструкции.
    В этот раз инструкции не нашел по моему вопросу
    Может кто поможет

  2. #2
    Senior Member Аватар для Армаэль
    Регистрация
    22.03.2015
    Адрес
    Москва
    Сообщений
    287

    По умолчанию

    wget https://github.com/phpredis/phpredis/archive/3.1.4.zip -O phpredis.zip
    unzip -q ./phpredis.zip

    cd ./phpredis-3.1.4
    /opt/php70/bin/phpize
    ./configure --with-php-config=/opt/php70/bin/php-config
    make && make install && make clean
    touch /opt/php70/etc/mods-available/redis.ini
    echo "extension=/opt/php70/lib/php/modules/redis.so" > /opt/php70/etc/mods-available/redis.ini
    killall core
    и включайте в php70 экстеншн redis, и так далее для остальных версий
    Dedicated server Fujitsu-Siemens TX150 S7 | Intel Xeon X3430 | 32GB RAM ECC REG | IBM SAS 15k 300Gbx4 | WD SATA 7.2k 1Tbx4 | Intel Pro 1Gb LAN | Ubuntu Server 16.04 | ISPmanager 5 Lite

Ваши права

  • Вы не можете создавать новые темы
  • Вы не можете отвечать в темах
  • Вы не можете прикреплять вложения
  • Вы не можете редактировать свои сообщения
  •