Показано с 1 по 4 из 4

Тема: PHP native

  1. #1
    Junior Member
    Регистрация
    02.11.2018
    Сообщений
    3

    По умолчанию PHP native

    Всех приветствую!

    В панели (ispmanager) установлено несколько версий php 5.6 7.0 и 7.2
    из них 5.6 (native) но меня это не устраивает потому как composer не устанавливает пакеты которые просят php 7.1
    консоль по команде php -v отдает версию 5.6
    Подскажите как сменить ее на 7.2 всю панель перерыл потом еще раз перерыл, потом с другом проконсультировался
    и еще раз все пересмотрел...

    где можно сменить версию php native с 5.6 на 7.2

    Заранее спасибо

  2. #2
    Junior Member
    Регистрация
    02.11.2018
    Сообщений
    3

    По умолчанию

    Цитата Сообщение от Stanley Посмотреть сообщение
    Всех приветствую!

    В панели (ispmanager) установлено несколько версий php 5.6 7.0 и 7.2
    из них 5.6 (native) но меня это не устраивает потому как composer не устанавливает пакеты которые просят php 7.1
    консоль по команде php -v отдает версию 5.6
    Подскажите как сменить ее на 7.2 всю панель перерыл потом еще раз перерыл, потом с другом проконсультировался
    и еще раз все пересмотрел...

    где можно сменить версию php native с 5.6 на 7.2

    Заранее спасибо
    Кароч вот команда чтоб игнорировать php

    compоser install --ignore-platform-reqs

  3. #3
    Junior Member
    Регистрация
    02.11.2018
    Сообщений
    3

    По умолчанию

    Кароч теперь проблема в другом

    теперь не работает artisan в ларавел..

    PHP Parse error: syntax error, unexpected '?' in /var/www/service-man/data/www/kit.vsbrain.ru/vendor/laravel/framework/src/Illuminate/Foundation/helpers.php on line 500


    Скажите как сменить консольную версию php так чтоб не повредить ispmanager

  4. #4
    Senior Member
    Регистрация
    09.04.2013
    Адрес
    Москва
    Сообщений
    2,007

    По умолчанию

    Запускайте php нужной версии с папки /opt/

Метки этой темы

Ваши права

  • Вы не можете создавать новые темы
  • Вы не можете отвечать в темах
  • Вы не можете прикреплять вложения
  • Вы не можете редактировать свои сообщения
  •