Добрый день!

Система Debian 8.11 + ISPManager 5.178.0-3-deb8. Установлены ISP-пакеты php70, php71, php72.

Клиент пожаловался на то, что не работает curl для версии php71.

Действительно, код ниже выдает ошибку 'Could not resolve host: ya.ru'. Остальные версии PHP работают нормально.

PHP код:
<?
$curl 
curl_init();
curl_setopt_array($curl, array(
    
CURLOPT_URL             => 'http://ya.ru',
    
CURLOPT_HEADER          => 1,
    
CURLOPT_RETURNTRANSFER  => 1,
    
CURLOPT_VERBOSE         => 1
));
$result curl_exec($curl);   
echo 
"<pre>\n";
echo 
phpversion() . "\n";
if(
$result) {
    
print_r($result);
} else {
    
print_r(curl_error($curl));
}   
echo 
"</pre>\n";
curl_close($curl);
?>