Показано с 1 по 8 из 8

Тема: Server-status

  1. #1
    Junior Member
    Регистрация
    16.11.2010
    Сообщений
    9

    По умолчанию Server-status

    Приветствую!
    Помогите, пожалуйста, победить server-status.
    В /etc/httpd/conf/httpd.conf раскоментировал/указал:
    Код:
    ExtendedStatus On
    <Location /server-status>
    	SetHandler server-status
    	Order deny,allow
    	Deny from all
    	Allow from 127.0.0.1
    	Allow from 80.234.xxx.xxx (мой IP)
    </Location>
    В адресной строке набираю https://194.58.xxx.xxx/server-status и вижу страницу ISPManager "404 Не найден. Запрашиваемая вами панель управления не найдена".
    ОС – CentOS release 6.10 (Final), ISPmanager Lite 5.200.0

  2. #2
    Member Аватар для Besar
    Регистрация
    01.06.2019
    Сообщений
    33

    По умолчанию

    Я так делаю:
    Код:
    <Location /server-status>
    	SetHandler server-status
    </Location>
    Открывается со всех ip и сайтов на сервере, поэтому дополнительно меняю ссылку от любопытных глаз, вместо:
    Код:
    <Location /server-status>
    ставлю:
    Код:
    <Location /своя-ссылка>

  3. #3

    По умолчанию

    Прописываете это в конфиге служебного сайта, а не в общем конфиге и будет отображаться только на одном служебном домене

  4. #4
    Junior Member
    Регистрация
    16.11.2010
    Сообщений
    9

    По умолчанию

    Цитата Сообщение от Besar Посмотреть сообщение
    Я так делаю:
    Код:
    <Location /server-status>
    	SetHandler server-status
    </Location>
    Сделал так, то же самое, страница ISPManager с 404 ошибкой.

    Цитата Сообщение от Pegas-x Посмотреть сообщение
    Прописываете это в конфиге служебного сайта, а не в общем конфиге и будет отображаться только на одном служебном домене
    Не совсем понял, что имеется в виду под служебным сайтом. Прописал в конфиге приоритетного www-домена. По ссылке https://m112.ru/server-status вижу страницу сайта на этом домене с 404 ошибкой.

  5. #5

    По умолчанию

    Надеюсь перед этим вы сделали следующее:
    Код:
    1. Открываем конфиг httpd - /etc/httpd/conf/httpd.conf
    
    2. Закомментируем там строки:
    
    <Location /server-status>
        SetHandler server-status
        Order deny,allow
        Deny from all
        Allow from 127.0.0.1
    </Location>
    
    3. Создаем (раскомментируем) там директиву:
    
    ExtendedStatus On
    
    4. Перезапускаем Apache (HTTP, httpd)

  6. #6
    Junior Member
    Регистрация
    16.11.2010
    Сообщений
    9

    По умолчанию

    Цитата Сообщение от Pegas-x Посмотреть сообщение
    Надеюсь перед этим вы сделали следующее:
    <...>
    Честно говоря, нет. Сейчас закомментировал в основном конфиге блок <Location>. ExtendedStatus там постоянно был и есть "On". В файле /etc/httpd/conf/vhosts/m112/m112.ru добавил
    Код:
    <Location /server-status>
        SetHandler server-status
    </Location>
    Вариант с Deny, Allow и своим IP тоже пробовал, разницы нет
    Делаю рестарт: /etc/init.d/httpd restart
    Эффект тот же, 404 ошибка при обращении к https://m112.ru/server-status

  7. #7

    По умолчанию

    А у вас часом не CMS 404 страничку генерирует?
    Потому как если идет запрос на скрипт, server status вы не увидите.
    Сделайте что то вроде:

    Код:
    <Location /своя-ссылка/тут-нечто>

  8. #8
    Junior Member
    Регистрация
    16.11.2010
    Сообщений
    9

    По умолчанию

    Попробовал <Location /server-01>, то же самое. Страницу генерирует CMS, но, насколько я понимаю, после того, как получит от сервера ответ 404. CMS — Joomla, в компоненте sh404SEF я вижу эти свои запросы — /server-status, /server-01. Но они никуда не переадресованы. На всякий случай покажу свой .htaccess, сам я не могу понять, какие строки на что влияют.
    А что, нет ли какого-нибудь способа смотреть server-status по старинке, по адресу ip-сервера/server-status? Пусть даже это будет в чем-то небезопасно.

    Код:
    <IfModule autoindex>
      IndexIgnore *
    </IfModule>
    <IfModule mod_headers.c>
    Header always set X-Content-Type-Options "nosniff"
    </IfModule>
    Options +FollowSymlinks
    Options -Indexes
    RewriteEngine On
    RewriteCond %{QUERY_STRING} base64_encode[^(]*\([^)]*\) [OR]
    RewriteCond %{QUERY_STRING} (<|%3C)([^s]*s)+cript.*(>|%3E) [NC,OR]
    RewriteCond %{QUERY_STRING} GLOBALS(=|\[|\%[0-9A-Z]{0,2}) [OR]
    RewriteCond %{QUERY_STRING} _REQUEST(=|\[|\%[0-9A-Z]{0,2})
    RewriteRule .* index.php [F]
    RewriteRule .* - [E=HTTP_AUTHORIZATION:%{HTTP:Authorization}]
    RewriteCond %{REQUEST_URI} !^/index\.php
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule .* index.php [L]
    RewriteCond %{HTTP_HOST} ^www\.(.*)$
    RewriteRule ^(.*)$ http://%1/$1 [L,R=301]

Ваши права

  • Вы не можете создавать новые темы
  • Вы не можете отвечать в темах
  • Вы не можете прикреплять вложения
  • Вы не можете редактировать свои сообщения
  •