Показано с 1 по 9 из 9

Тема: Конфликт версий libssl

  1. #1
    Junior Member
    Регистрация
    17.06.2019
    Сообщений
    1

    По умолчанию Конфликт версий libssl

    После обновления сервера на Debian с 8 до 9 версии невозможно осуществить вход в панель через браузер. Не открывается форма входа и не приходит ответ от сервера.

    Репозиторий в /etc/apt/sources.list.d поменял на
    Код:
    deb http://download.ispsystem.com/repo/debian base-stretch main
    ihttpd запущен и работает.

    В ispmgr.log выводится следующая ошибка:
    Код:
    FATAL Library libssl linked to /usr/lib/x86_64-linux-gnu/libssl.so.1.0.2 conflicting with already loaded one.
    При просмотре установленных пакетов отображается несколько сразу установленных версий.
    Код:
    ii  libssl1.0.0:amd64                                     1.0.1t-1+deb8u11                amd64                           Secure Sockets Layer toolkit - shared libraries
    ii  libssl1.0.2:amd64                                     1.0.2r-1~deb9u1                 amd64                           Secure Sockets Layer toolkit - shared libraries
    ii  libssl1.1:amd64                                       1.1.0j-1~deb9u1                 amd64                           Secure Sockets Layer toolkit - shared libraries
    Вопрос: как избавиться от конфликта библиотек libssl?

    При попытке удаления устаревших пакетов, к удалению предлагаются чуть ли не пол-сервера.
    Код:
    root@server:/usr/bin# apt-get remove libssl1.0.0
    Чтение списков пакетов… Готово
    Построение дерева зависимостей
    Чтение информации о состоянии… Готово
    Следующие пакеты устанавливались автоматически и больше не требуются:
      apache2-data apache2-utils apt-transport-https aspell aspell-en at bind9 bind9-host bind9utils dbconfig-common dbconfig-mysql dictionaries-common dirmngr dnsutils dovecot-core dovecot-imapd dovecot-pop3d dovecot-sieve emacsen-common
      fontconfig-config fonts-dejavu-core fonts-droid freetds-common geoip-bin geoip-database ghostscript gsfonts imagemagick-common ipset javascript-common libaio1 libapr1 libaprutil1 libaprutil1-dbd-sqlite3 libaprutil1-ldap libaspell15
      libassuan0 libavahi-client3 libavahi-common-data libavahi-common3 libberkeleydb-perl libbind9-140 libc-client2007e libct4 libcups2 libcupsfilters1 libcupsimage2 libdbd-mysql-perl libdbi-perl libdigest-hmac-perl libdns162 libetpan-isp
      libexttextcat-2.0-0 libexttextcat-data libfcgi0ldbl libfftw3-double3 libfontconfig1 libgd3 libgeoip1 libgomp1 libgs9 libgs9-common libhtml-template-perl libijs-0.35 libio-multiplex-perl libio-socket-inet6-perl libipset3 libirs141
      libisc160 libisccc140 libisccfg140 libjbig0 libjbig2dec0 libjpeg62-turbo libjs-jquery libjs-sphinxdoc libjs-underscore libjsoncpp0 libksba8 liblcms2-2 liblqr-1-0 libltdl7 liblua5.1-0 liblwres141 libmagickcore-6.q16-2
      libmagickwand-6.q16-2 libmcrypt4 libmemcached11 libmemcachedutil2 libmhash2 libmicrohttpd12-isp libnet-cidr-perl libnet-dns-perl libnet-ip-perl libnet-rblclient-perl libnet-server-perl libodbc1 libonig2 libopendbx1
      libopendbx1-sqlite3 libopendkim11 libopenjp2-7 libopts25 libpaper-utils libpaper1 libparse-syslog-perl libpng12-0 libpth20 libqdbm14 libqrencode3 librbl1 librecode0 libsensors4 libsnmp-base libsocket6-perl libstemmer0d libsybdb5
      libterm-readkey-perl libtext-template-perl libtidy-0.99-0 libtiff5 libunbound2 libvbr2 libvpx1 libwebp5 libwebp6 libxpm4 libxslt1.1 mlock mysql-client-5.5 mysql-server mysql-server-5.5 mysql-server-core-5.5 mysqltuner nginx ntp
      ntpdate opendkim-tools php-auth php-auth-sasl php-common php-db php-gettext php-log php-mail php-mail-mime php-mail-mimedecode php-mbstring php-mdb2 php-net-smtp php-net-socket php-pear php-php-gettext php-soap php-tcpdf php-xml
      php5-gd php5-intl php5-json php5-mcrypt php5-mysql php5-pspell php5-sqlite php7.0-cli php7.0-common php7.0-json php7.0-mbstring php7.0-opcache php7.0-readline php7.0-soap php7.0-xml poppler-data postgrey pwauth pwgen qrencode
      roundcube-mysql rsync shellinabox ssl-cert
    Для их удаления используйте «apt-get autoremove».
    Пакеты, которые будут УДАЛЕНЫ:
      apache2 apache2-bin apache2-mpm-itk coremanager coremanager-pkg-bind coremanager-pkg-mysql isp-php52 isp-php53 isp-php54 isp-php55 isp-php56 isp-php71 isp-php71-fpm ispmanager-lite-common ispmanager-pkg-bind ispmanager-pkg-dovecot
      ispmanager-pkg-exim ispmanager-pkg-greylisting-exim ispmanager-pkg-httpd-itk ispmanager-pkg-myadmin ispmanager-pkg-mysql ispmanager-pkg-nginx ispmanager-pkg-opendkim-exim ispmanager-pkg-php ispmanager-pkg-phpfpm
      ispmanager-pkg-proftpd ispmanager-pkg-roundcube ispmanager-plugin-letsencrypt ispmanager-plugin-revisium ispmanager-plugins libapache2-mod-authnz-external libapache2-mod-php5 libapache2-mod-rpaf libapache2-mpm-itk libsnmp30
      libssl1.0.0 php5-cgi php5-cli php5-fpm php5-imap php5-readline phpmyadmin proftpd-basic roundcube roundcube-core
    обновлено 0, установлено 0 новых пакетов, для удаления отмечено 45 пакетов, и 0 пакетов не обновлено.
    После данной операции, объём занятого дискового пространства уменьшится на 408 MB.
    Хотите продолжить? [Д/н] n

  2. #2
    Junior Member
    Регистрация
    10.07.2016
    Сообщений
    2

    По умолчанию

    Имею такую же проблему. Решили как то?

  3. #3
    Senior Member
    Регистрация
    02.03.2013
    Сообщений
    109

    По умолчанию

    Аналогичная проблема.
    Решили как-то?

  4. #4
    Senior Member Аватар для Iliaxxx
    Регистрация
    25.05.2011
    Сообщений
    400

    По умолчанию

    Насколько я помню в ISPmaager нельзя обновлять версии сервера, только путем установки чистого сервера и накатывается панель.
    Вы обновляете версию панели лайт или бизнес?

  5. #5
    Senior Member
    Регистрация
    02.03.2013
    Сообщений
    109

    По умолчанию

    Lite

  6. #6
    Member Аватар для Besar
    Регистрация
    01.06.2019
    Сообщений
    45

    По умолчанию

    Панель устанавливать нужно на чистую ОС, всё остальное "танцы с бубном", особенно без познаний администрирования.

  7. #7
    Senior Member Аватар для Iliaxxx
    Регистрация
    25.05.2011
    Сообщений
    400

    По умолчанию

    Цитата Сообщение от lyric Посмотреть сообщение
    Lite
    В любом случае, такой вопрос задавался тут уже не раз, ошибки разные просто у всех. Разрабы советуют не обновлять, а ставить чистую панель и на нее уже переносить все.
    С бизнес версией вообще тут все печально, она идет только на 8-ой версии, которая прекращает свой жизненный путь в скором времени. И что дальше разрабы молчат.
    Последний раз редактировалось Iliaxxx; 28.03.2020 в 18:02.

  8. #8
    Senior Member Аватар для Iliaxxx
    Регистрация
    25.05.2011
    Сообщений
    400

    По умолчанию

    У меня например на сервере бизнес много сайтов, почты за терабайт перевалило. Да и в целом за годы эксплуатации я сильно его кастомизировал. Но теперь пора переходить, а переходить ровным счетом некуда, осталось в поддержке только centOS 7 и все. Крутись как хочешь. Как представлю сколько было сделано и что мне теперь все это нужно будет переделывать, даже непосебе становится.

  9. #9
    Senior Member
    Регистрация
    02.03.2013
    Сообщений
    109

    По умолчанию

    Вопрос решил изменением репозиториев панели с jessie на stretch:
    Код:
    #cat /etc/apt/sources.list.d/ispsystem-base.list
    deb http://download.ispsystem.com/repo/debian base-stretch main
    #cat /etc/apt/sources.list.d/ispsystem.list
    ###deb http://download.ispsystem.com/repo/debian __VERSION__-stretch main
    deb http://download.ispsystem.com/repo/debian 5.246-stretch main
    и apt-get update && apt-get upgrade && apt-get dist-upgrade

    Режим работы явно не предусмотрен разработчиками: лично у меня заработало, но как у вас поведет себя панель - неизвестно.

Ваши права

  • Вы не можете создавать новые темы
  • Вы не можете отвечать в темах
  • Вы не можете прикреплять вложения
  • Вы не можете редактировать свои сообщения
  •