Показано с 1 по 3 из 3

Тема: Необходимо обновить libxml2

  1. #1
    Junior Member
    Регистрация
    24.09.2019
    Сообщений
    2

    По умолчанию Необходимо обновить libxml2

    Здравствуйте.

    Centos 7.3 2.6.32-042stab123.1, панель ISPmanager Lite 5.217.0.

    Необходимо обновить libxml2(текущая версия libxml2-2.9.1-6.el7_2.3.x86_64), необходима не ниже 2.9.3.

    Что делал:
    yum update libxml2
    В ответ:
    No packages marked for update

    Попытался собрать из исходников, попросил gcc, gcc в свою очередь тянет новое ядро системы 3.10 как зависимость.

    В общем то вопрос: как обновить libxml2?
    И не рухнет ли система после обновления ядра?

    Если что то не указал, спрашивайте...

  2. #2
    Support team Аватар для zaqwer101
    Регистрация
    18.09.2017
    Сообщений
    48

    По умолчанию

    На форуме CentOS пишут, что в самой системе это ничего повредить не должно, даже процесс примерно описан:
    https://www.centos.org/forums/viewto...=59124#p249777

    разве что после обновления ядра нужно будет перезагрузиться.

    Но ISPmanager после такого вполне может перестать работать, потому что в панелях очень многое завязано на работе с XML, в том числе при помощи этой библиотеки:
    [root@lite mgr5]# ldd /usr/local/mgr5/lib/libmgr.so | grep libxml
    libxml2.so.2 => /lib64/libxml2.so.2 (0x00007f48b645e000)

    Можно попробовать сделать снапшот сервера, пересобрать библиотеку, после чего перезапустить панель (/usr/local/mgr5/sbin/mgrctl -m core -R && /usr/local/mgr5/sbin/mgrctl -m ispmgr -R) и посмотреть что будет.

  3. #3
    Junior Member
    Регистрация
    24.09.2019
    Сообщений
    2

    По умолчанию

    В том то и дело, за сам Centos я не переживаю, обновлял не однократно, но с панелью опыта не было.
    Попробую на выходных.

Ваши права

  • Вы не можете создавать новые темы
  • Вы не можете отвечать в темах
  • Вы не можете прикреплять вложения
  • Вы не можете редактировать свои сообщения
  •