Показано с 1 по 4 из 4

Тема: Проблема с модулем Let`s Encrypt

  1. #1
    Junior Member
    Регистрация
    20.09.2018
    Сообщений
    3

    По умолчанию Проблема с модулем Let`s Encrypt

    Добрый день.
    При обновлении либо получении сертификата модулем Let`s Encrypt стала выходить ошибка:
    return code:400
    Details:JWS has no anti-replay nonce

    http://prntscr.com/picjul

    И сертификат не удается получить.

  2. #2
    Support team Аватар для zaqwer101
    Регистрация
    18.09.2017
    Сообщений
    50

    По умолчанию

    Скорее всего используется пакет libcurl, обновленный из стороннего репозитория до неподдерживаемой версии. Если на сервере установлена CentOS 7, то нужно сделать даунгрейд libcurl до версии 7.29 и перезапустить панель.

  3. #3
    Junior Member
    Регистрация
    20.09.2018
    Сообщений
    3

    По умолчанию

    Большое спасибо!
    На всякий случай, оставлю инструкцию для тех кто тоже столкнется с этой проблемой:

    1. Смотрим версию и видим левый репозиторий и пакеты которые он затронул:
    yum list installed | grep curl
    http://prntscr.com/pilg5s

    2. Смотрим имя левого репозитория:
    yum repolist
    3. Отключаем левый репозиторий:
    yum-config-manager --disable CityFan
    4. Пересобираем кэш yum:
    yum clean all
    yum makecache
    5. Довнгрейдим пакеты:
    yum downgrade curl libcurl

    6. Убеждаемся, что все в порядке:
    yum list installed | grep curl
    http://prntscr.com/piljlt

    7. Перезагружаем сервер и при необходимости, запрашиваем снова обновление/получение сертификата (у меня без повторного запроса прошло).

  4. #4
    Support team Аватар для zaqwer101
    Регистрация
    18.09.2017
    Сообщений
    50

    Lightbulb

    Благодарю за подробную инструкцию, всё верно, но:
    Цитата Сообщение от xanet Посмотреть сообщение
    7. Перезагружаем сервер и при необходимости, запрашиваем снова обновление/получение сертификата (у меня без повторного запроса прошло).
    сервер перезагружать необязательно Обычно достаточно перезапустить панель, выполнив команду:
    /usr/local/mgr5/sbin/mgrctl -m ispmgr -R

Метки этой темы

Ваши права

  • Вы не можете создавать новые темы
  • Вы не можете отвечать в темах
  • Вы не можете прикреплять вложения
  • Вы не можете редактировать свои сообщения
  •