Показано с 1 по 7 из 7

Тема: Зависимости в Centos 7

  1. #1
    Junior Member
    Регистрация
    03.06.2016
    Сообщений
    5

    По умолчанию Зависимости в Centos 7

    Здравствуйте, после недавнего обновления Centos 7 нарушились зависимости php пакетов, не могли бы пересобрать

    Код:
    Resolving Dependencies
    --> Running transaction check
    ---> Package ImageMagick.x86_64 0:6.7.8.9-18.el7 will be updated
    --> Processing Dependency: libMagickCore.so.5()(64bit) for package: isp-php56-5.6.40-382.el7.centos.x86_64
    --> Processing Dependency: libMagickCore.so.5()(64bit) for package: isp-php53-5.3.29-379.el7.centos.x86_64
    --> Processing Dependency: libMagickCore.so.5()(64bit) for package: isp-php71-7.1.33-348.el7.centos.x86_64
    --> Processing Dependency: libMagickCore.so.5()(64bit) for package: isp-php72-7.2.29-408.el7.x86_64
    --> Processing Dependency: libMagickWand.so.5()(64bit) for package: isp-php56-5.6.40-382.el7.centos.x86_64
    --> Processing Dependency: libMagickWand.so.5()(64bit) for package: isp-php53-5.3.29-379.el7.centos.x86_64
    --> Processing Dependency: libMagickWand.so.5()(64bit) for package: isp-php71-7.1.33-348.el7.centos.x86_64
    --> Processing Dependency: libMagickWand.so.5()(64bit) for package: isp-php72-7.2.29-408.el7.x86_64
    ---> Package ImageMagick.x86_64 0:6.9.10.68-3.el7 will be an update
    
    Packages skipped because of dependency problems:
        ImageMagick-6.9.10.68-3.el7.x86_64 from cr

  2. #2

    По умолчанию

    Здравствуйте.

    У Вас пакет из CR обновиться пытается. Это тестовый репозиторий. Пакеты из него пока ещё не вошли в основной репозиторий.

  3. #3
    Junior Member
    Регистрация
    03.06.2016
    Сообщений
    5

    По умолчанию

    с очень большой долей вероятности такие же будет и в основном, и пересобирать всё равно потребуется
    Подскажите, когда Вы это сделаете?
    Последний раз редактировалось flo; 17.04.2020 в 02:08.

  4. #4

    По умолчанию

    Цитата Сообщение от flo Посмотреть сообщение
    с очень большой долей вероятности такие же будет и в основном, и пересобирать всё равно потребуется
    Подскажите, когда Вы это сделаете?
    Тогда, когда этот пакет появится в основном репозитории. Если это сделать сейчас, то PHP не сможет установиться у всех, кто не используется тестовый репозиторий centos

  5. #5
    Junior Member
    Регистрация
    03.06.2016
    Сообщений
    5

    По умолчанию

    Спасибо

  6. #6
    Junior Member
    Регистрация
    28.04.2020
    Сообщений
    1

    По умолчанию

    Аналогичная проблема возникла:
    Код:
    ---> Package ImageMagick.x86_64 0:6.9.10.68-3.el7 will be an update
    --> Finished Dependency Resolution
    Error: Package: isp-php56-5.6.40-382.el7.centos.x86_64 (@ispsystem-base)
               Requires: libMagickCore.so.5()(64bit)
               Removing: ImageMagick-6.7.8.9-18.el7.x86_64 (@base)
                   libMagickCore.so.5()(64bit)
               Updated By: ImageMagick-6.9.10.68-3.el7.x86_64 (base)
                   Not found
    Error: Package: isp-php71-7.1.33-348.el7.centos.x86_64 (@ispsystem-base)
               Requires: libMagickCore.so.5()(64bit)
               Removing: ImageMagick-6.7.8.9-18.el7.x86_64 (@base)
                   libMagickCore.so.5()(64bit)
               Updated By: ImageMagick-6.9.10.68-3.el7.x86_64 (base)
                   Not found
    Error: Package: isp-php73-7.3.16-408.el7.x86_64 (@ispsystem-base)
               Requires: libMagickCore.so.5()(64bit)
               Removing: ImageMagick-6.7.8.9-18.el7.x86_64 (@base)
                   libMagickCore.so.5()(64bit)
               Updated By: ImageMagick-6.9.10.68-3.el7.x86_64 (base)
                   Not found
    Error: Package: isp-php71-7.1.33-348.el7.centos.x86_64 (@ispsystem-base)
               Requires: libMagickWand.so.5()(64bit)
               Removing: ImageMagick-6.7.8.9-18.el7.x86_64 (@base)
                   libMagickWand.so.5()(64bit)
               Updated By: ImageMagick-6.9.10.68-3.el7.x86_64 (base)
                   Not found
    Error: Package: isp-php56-5.6.40-382.el7.centos.x86_64 (@ispsystem-base)
               Requires: libMagickWand.so.5()(64bit)
               Removing: ImageMagick-6.7.8.9-18.el7.x86_64 (@base)
                   libMagickWand.so.5()(64bit)
               Updated By: ImageMagick-6.9.10.68-3.el7.x86_64 (base)
                   Not found
    Error: Package: isp-php73-7.3.16-408.el7.x86_64 (@ispsystem-base)
               Requires: libMagickWand.so.5()(64bit)
               Removing: ImageMagick-6.7.8.9-18.el7.x86_64 (@base)
                   libMagickWand.so.5()(64bit)
               Updated By: ImageMagick-6.9.10.68-3.el7.x86_64 (base)
                   Not found
    Error: Package: isp-php74-7.4.4-408.el7.x86_64 (@ispsystem-base)
               Requires: libMagickWand.so.5()(64bit)
               Removing: ImageMagick-6.7.8.9-18.el7.x86_64 (@base)
                   libMagickWand.so.5()(64bit)
               Updated By: ImageMagick-6.9.10.68-3.el7.x86_64 (base)
                   Not found
    Error: Package: isp-php74-7.4.4-408.el7.x86_64 (@ispsystem-base)
               Requires: libMagickCore.so.5()(64bit)
               Removing: ImageMagick-6.7.8.9-18.el7.x86_64 (@base)
                   libMagickCore.so.5()(64bit)
               Updated By: ImageMagick-6.9.10.68-3.el7.x86_64 (base)
                   Not found
    Когда можно ожидать будет исправление ситуации?
    Последний раз редактировалось Tigla; 28.04.2020 в 02:28.

  7. #7
    Junior Member
    Регистрация
    06.05.2020
    Сообщений
    2

    По умолчанию

    Цитата Сообщение от flo Посмотреть сообщение
    Здравствуйте, после недавнего обновления Centos 7 нарушились зависимости php пакетов, не могли бы пересобрать

    Код:
    Resolving Dependencies
    --> Running transaction check
    ---> Package ImageMagick.x86_64 0:6.7.8.9-18.el7 will be updated
    --> Processing Dependency: libMagickCore.so.5()(64bit) for package: isp-php56-5.6.40-382.el7.centos.x86_64
    --> Processing Dependency: libMagickCore.so.5()(64bit) for package: isp-php53-5.3.29-379.el7.centos.x86_64
    --> Processing Dependency: libMagickCore.so.5()(64bit) for package: isp-php71-7.1.33-348.el7.centos.x86_64
    --> Processing Dependency: libMagickCore.so.5()(64bit) for package: isp-php72-7.2.29-408.el7.x86_64
    --> Processing Dependency: libMagickWand.so.5()(64bit) for package: isp-php56-5.6.40-382.el7.centos.x86_64
    --> Processing Dependency: libMagickWand.so.5()(64bit) for package: isp-php53-5.3.29-379.el7.centos.x86_64
    --> Processing Dependency: libMagickWand.so.5()(64bit) for package: isp-php71-7.1.33-348.el7.centos.x86_64
    --> Processing Dependency: libMagickWand.so.5()(64bit) for package: isp-php72-7.2.29-408.el7.x86_64
    ---> Package ImageMagick.x86_64 0:6.9.10.68-3.el7 will be an update
    
    Packages skipped because of dependency problems:
        ImageMagick-6.9.10.68-3.el7.x86_64 from cr
    Я исключил обновление этого пакета ImageMagick командой:
    yum --exclude=imagemagick update

    Это помогло!

Ваши права

  • Вы не можете создавать новые темы
  • Вы не можете отвечать в темах
  • Вы не можете прикреплять вложения
  • Вы не можете редактировать свои сообщения
  •