Показано с 1 по 5 из 5

Тема: Проблемы настройки PHP на Ubuntu 20

  1. #1
    Junior Member
    Регистрация
    11.04.2016
    Сообщений
    11

    По умолчанию Проблемы настройки PHP на Ubuntu 20

    ISPmanager Lite 5.265.0 на Ubuntu 20 не отображаются настройки нативной PHP 7.4.3. Это только у меня такая проблема или баг. Насколько я понял под эту убунту недавно панель выкатили.

  2. #2
    Junior Member
    Регистрация
    11.04.2016
    Сообщений
    11

    По умолчанию

    В настройках просто пусто, в расширенях пишет "Невозможно получить список загруженных модулей PHP. Если ранее выполнялась установка расширения - попробуйте повторить запрос, в противном случае требуется проверка конфигурации PHP
    Попробовать снова" Настраивать получается только через конфиги можно. Это как в старом интерфейсе, так и в новом.

  3. #3
    Senior Member
    Регистрация
    16.01.2015
    Сообщений
    140

    По умолчанию

    Удалите через возможности, удалите папку /opt/php74

    сделайте sudo apt-get update и заново поставьте, php 7.4.3 у меня вообще косячно встала, не видела часть модулей, я переставил, поставилась 7.4.6 без проблемная

  4. #4
    Junior Member
    Регистрация
    11.04.2016
    Сообщений
    11

    По умолчанию

    Честно говоря уже замучился. 8 раз сношу сервак. Через возможности удалял, папки opt/php74 отродясь не было, при установке обычно раньше в возможностях выдавало установленную версию PHP, сейчас просто PHP-FPM, апачь не ставлю на сервер, всё на nginx. При этом при первоначальной установке через возможности понятное дело устанавливается fail2ban, это всегда было, но плюсом ставиться ревизиум этот и плюсом к нему идёт PHP 7.1 cgi как я понял. На нём настройки нормально работают, но на кой мне нужен мусор. Подозрение у меня что это гуано может косячить, на серваке с дебианом такой проблемы нет, но я уже с него слез давно, да и хотелось бы решить проблему.

  5. #5
    Junior Member
    Регистрация
    11.04.2016
    Сообщений
    11

    По умолчанию

    До смешного доходит. Ставлю апачь и полетели, все настройки/модули, всё работает. Уже задумался плюнуть и установить его. Но как то нелепо получается, я им совершенно не пользуюсь, благо ресурсов хватает на серваке. А если нет?
    Если ставлю альтернативную 7.4.8 то всё нормально, есть настройки, а нативная без изменений. Самое интересное что сам пых без нареканий работает. Пробовал уже пути переписывать, конфиги правил, в исп конфиги залез, толку ноль. Именно эта версия даёт такой результат.

Ваши права

  • Вы не можете создавать новые темы
  • Вы не можете отвечать в темах
  • Вы не можете прикреплять вложения
  • Вы не можете редактировать свои сообщения
  •