Показано с 1 по 8 из 8

Тема: isp-php53 проблемы

  1. #1
    Senior Member
    Регистрация
    16.12.2010
    Сообщений
    438

    По умолчанию isp-php53 проблемы

    на centos 7 после апдейта
    /opt/php53/bin/php -v
    PHP Warning: PHP Startup: Unable to load dynamic library '/opt/php53/lib/php/modules/mysqli.so' - /opt/php53/lib/php/modules/mysqli.so: undefined symbol: mysqlnd_connect in Unknown on line 0
    Debian 9/10 && Centos 7/8 ISPLite5

  2. #2
    Senior Member
    Регистрация
    16.12.2010
    Сообщений
    438

    По умолчанию

    решение
    unlink /opt/php53/etc/php.d/10-mysql.ini
    rm -f /opt/php53/etc/php.d/mysqlnd.ini
    cd /opt/php53/etc/php.d
    ln -s ../mods-available/mysqlnd.ini 10-mysqlnd.ini
    cp /opt/php53/etc/mods-available/mysql.ini /opt/php53/etc/php.d/
    Последний раз редактировалось Michael1; 14.09.2020 в 18:00.
    Debian 9/10 && Centos 7/8 ISPLite5

  3. #3
    Senior Member
    Регистрация
    16.12.2010
    Сообщений
    438

    По умолчанию

    debian 10 - php5.2 - расширения mysql mysqli вообще нет в пакете - не скомпилировано
    Debian 9/10 && Centos 7/8 ISPLite5

  4. #4
    Senior Member
    Регистрация
    06.03.2016
    Адрес
    UA
    Сообщений
    134

    По умолчанию

    5.2, 5.3.... Закопайте, а?

  5. #5
    Senior Member Аватар для Alex Keda
    Регистрация
    20.01.2009
    Адрес
    USSR
    Сообщений
    2,929

    По умолчанию

    куда копать?
    у меня у клиентов на нём с сотню сайтов, но именно эти клиенты приносят весомую часть прибыли.

    а в центосе8 mysqli на 5.2 вообще не подгружается, но это я уже отписал в саппорт

    как и о том что на 8 центосе используется mysql8, а с ним mysqli из версий 5.x не работает, так как собраны со старым mysql клиентом
    Убей их всех! Бог потом рассортирует...

  6. #6
    Senior Member
    Регистрация
    16.12.2010
    Сообщений
    438

    По умолчанию

    да уж - невозможно поставить mariadb в centos8 вместо mysql8 - не дают зависимости coremanager от mysql8
    Debian 9/10 && Centos 7/8 ISPLite5

  7. #7
    Senior Member
    Регистрация
    09.04.2013
    Адрес
    Москва
    Сообщений
    2,085

    По умолчанию

    Это нормально)
    Спустя годик можно будет переходить на centos 8 + isp
    Либо сейчас и записываться в живые альфа/бета тестеры

  8. #8
    Senior Member Аватар для Alex Keda
    Регистрация
    20.01.2009
    Адрес
    USSR
    Сообщений
    2,929

    По умолчанию

    я уже записался.
    первую неделю по тикету-два писал... в день...

    щас вроде устаканилось, но например все альт-версии php mysqli собраны со старым клиентом mysql и с mysql8 не работают - говорят что анконовн чарсет - там по дефолту utf8mb4...

    уже 12 дней думают над моим тикетом с этим описанием и предложением собрать хотя бы с MySQL 5.5.3 где появился utf8mb4

    и не все сайты могут mysql или PDO...
    Убей их всех! Бог потом рассортирует...

Ваши права

  • Вы не можете создавать новые темы
  • Вы не можете отвечать в темах
  • Вы не можете прикреплять вложения
  • Вы не можете редактировать свои сообщения
  •