Страница 2 из 3 ПерваяПервая 123 ПоследняяПоследняя
Показано с 11 по 20 из 25

Тема: Пожалуйста подскажите как обновить PHP

  1. #11
    Member
    Регистрация
    20.09.2007
    Сообщений
    33

    По умолчанию

    Цитата Сообщение от Solven Посмотреть сообщение
    Сделал сию штуку, установилось 5.3.1.
    Сайты легли, пхп тоже...
    Ошибка в совете "yum --enablerepo=remi update php"
    так по любому поставится 5.3.1
    то что легли сайты это нормально явление в данной ситуации.
    Основная проблема в том, что начиная с 5.3 нужно вместо <?...?> писать <?php...php?>
    Но более простым способом была бы "поднастройка" в конфиге чтобы и вариант с <?...?> отрабатывал.

    Сейчас для быстрого решения предложу сделать так
    # yum remove php
    # yum install php (без "--enablerepo=remi") поставится 5.1.х
    Кстати чем это вас смущает?, ведь политика редхата(центоса) не менять минорную версию пакета при незначительных изменениях. Если вы посмотрите дату сборки установленного по yum install php, то обратите внимание на то, что эта дата будет свежее чем 5.2.9

  2. #12
    Member
    Регистрация
    20.09.2007
    Сообщений
    33

    По умолчанию

    Цитата Сообщение от RHS Посмотреть сообщение
    PHP 5.3.x - редкостная ерунда! Когда сервер на CentOS 5 x86_64 автоматически обновился с remi, клиенты взвыли! ZendOptmizer сдох сразу, вывалились горы ошибок, mcrypt и ncusers я вообще не нашел как факт. Версия 5.2.10 на remi-репозитории уже отсутствует. Пришлось с ftp://centos.alt.ru/pub/php-fpm/5.2....L/RPMS/x86_64/ ручками при помощи wget качать и ставить. В результате теперь возможность панели ISPManager "установка расширений PHP" не пашет. В "родном" репозитории CentOS по-прежднему допотопная 5.1.6, от которой клиенты завоют не меньше. Думаю. что делать.
    Вопрос: Подскажите, есть ли в природе YUM-репозитории для CentOS (RHEL) 5, с версиями PHP 5.2.8-5.2.10?
    Совет: Не обновляйтесь до 5.3.х, пока еще рано, потому что криво! Запаритесь потом с откатом! Придется полгодика подождать.
    Не стоит вводить людей в заблуждение, если не владеете воросом
    5.3 уже очень давно является стабильным и имеет массу возможностей, которые отсутствовали в 5.2.х
    сносится через yum remove на раз два, насчет зенда, без проблем но зачем зенд, если рациональней использоваться APC, mcrypt и ncusers ставится через тот же yum...
    У меня на нескольких серверах стоит 5.3.1 на некоторых еще старый 5.1.6 и никто не воет )))

  3. #13
    Cool UNIX admin Аватар для ls
    Регистрация
    12.03.2007
    Сообщений
    10,471

    По умолчанию

    5.2.10 уже давно нет в этом репозитории, обновленная инструкция http://ru.ispdoc.com/index.php/Обнов..._CentOS_Linux

  4. #14
    Member Аватар для Solven
    Регистрация
    18.09.2009
    Сообщений
    80

    По умолчанию

    Цитата Сообщение от AndreyDV Посмотреть сообщение
    Ошибка в совете "yum --enablerepo=remi update php"
    так по любому поставится 5.3.1
    то что легли сайты это нормально явление в данной ситуации.
    Основная проблема в том, что начиная с 5.3 нужно вместо <?...?> писать <?php...php?>
    Но более простым способом была бы "поднастройка" в конфиге чтобы и вариант с <?...?> отрабатывал.

    Сейчас для быстрого решения предложу сделать так
    # yum remove php
    # yum install php (без "--enablerepo=remi") поставится 5.1.х
    Кстати чем это вас смущает?, ведь политика редхата(центоса) не менять минорную версию пакета при незначительных изменениях. Если вы посмотрите дату сборки установленного по yum install php, то обратите внимание на то, что эта дата будет свежее чем 5.2.9
    Это конечно жесть! Просто нет слов....
    Снесли и поставили 5.2.10, пхп не заводится... ( при заходе в панели во вкладку "Расширения PHP" выскакивает табличка с ошибкой "Can't open dir /usr/lib/php4")


    добавил строчку в ispmgr.conf
    path php-extensions /usr/lib/php/modules
    почему то её не было..


    пхп пока так и не пашет...


    причина обновления была из за magento, который просит минимум 5.2 версию.....
    Стояла до этого 5.1.16.... доволен был до уср...и
    Последний раз редактировалось Solven; 29.01.2010 в 02:17.

  5. #15
    Member Аватар для Solven
    Регистрация
    18.09.2009
    Сообщений
    80

    По умолчанию

    Цитата Сообщение от ls Посмотреть сообщение
    5.2.10 уже давно нет в этом репозитории, обновленная инструкция http://ru.ispdoc.com/index.php/Обнов..._CentOS_Linux
    Жалко конечно что его там не оказалось.. )))

  6. #16
    Member
    Регистрация
    20.09.2007
    Сообщений
    33

    По умолчанию

    Цитата Сообщение от Solven Посмотреть сообщение
    причина обновления была из за magento, который просит минимум 5.2 версию.....
    Стояла до этого 5.1.16.... доволен был до уср...и
    Я бы вам посоветовал собрать тогда php ручками. Это не так сложно, зато версия будет та что нужно и панель ее увидит.
    Если вы этого не делали, могу подсказать строку configure (в которой включено все нужное для большинства написанного софта).

  7. #17
    Cool UNIX admin Аватар для ls
    Регистрация
    12.03.2007
    Сообщений
    10,471

    По умолчанию

    http://rpms.famillecollet.com/enterprise/5/
    внизу ссылки Not a repository, not maintained, just for history на i386 и x86_64
    качаете оттуда RPMки и ставите вручную 5.2.10 на здоровье

    Не надо ничего собирать руками

  8. #18
    Member Аватар для Solven
    Регистрация
    18.09.2009
    Сообщений
    80

    По умолчанию

    От сюда вроде все и собрали ))

  9. #19
    Senior Member
    Регистрация
    21.01.2010
    Сообщений
    112

    По умолчанию

    жесть установил gd командой yum install php-gd он пшп обновил теперь пшп как модуль CGI не работает.тоесть Internal Server Error на сайтах.
    где что править чтобы CGI вернуть.пшп встала версия PHP 5.3.1
    хм ос CentOS

  10. #20
    Senior Member Аватар для xaker1
    Регистрация
    30.06.2009
    Сообщений
    2,739

    По умолчанию

    Ставьте php 5.x.x. C php 5.3 много проблем, как обновиться с помощью rpm ищите на форуме, я описывал.
    Стоит один раз попробовать что бы влюбиться... в ISP.

    На все мои сообщения, действует конфигурация сервера: ISP Pro (всегда актуальная current версия), FreeBSD 8.0, php as fcgi, nginx+apache.

    Бесплатные плагины для ISPmanager.

Метки этой темы

Ваши права

  • Вы не можете создавать новые темы
  • Вы не можете отвечать в темах
  • Вы не можете прикреплять вложения
  • Вы не можете редактировать свои сообщения
  •