Показано с 1 по 6 из 6

Тема: проблема при установке nginx

  1. #1
    Senior Member
    Регистрация
    14.03.2012
    Адрес
    Ukraine, Lviv
    Сообщений
    724

    По умолчанию проблема при установке nginx

    Ставлю nginx через панель управления, не ставит, в логах вот что
    PHP код:
    Mar 16 02:29:16 [16954:0] [1;32mINFO Requestinstall nginx[0m
    Mar 16 02
    :29:16 [16954:0] ../../src/mgr/install/pkgctl.cpp:687 [1mTRACE Init pkgmgr[0m
    Mar 16 02
    :29:16 [16954:0] [1;32mINFO Using package manager 'Apt'[0m
    Mar 16 02
    :29:16 [16954:0] ../../src/mgr/install/pkgctl.cpp:689 [1mTRACE Init way[0m
    Mar 16 02
    :29:16 [16954:0] ../../src/mgr/install/pkgctl.cpp:691 [1mTRACE Init client[0m
    Mar 16 02
    :29:16 [16954:0] ../../src/mgr/install/pkgctl.cpp:697 [1mTRACE Done[0m
    Mar 16 02
    :29:16 [16954:0] ../../src/mgr/install/pkgctl.cpp:536 [1mTRACE LoadModule lib/pkgisp-nginx.so[0m
    Mar 16 02
    :29:16 [16954:0] [1;36mEXTINFO Execute (/bin/egrep -'^Package: |^Version: ' /var/lib/apt/lists/*_Packages) return=0 exited[0m
    Mar 16 02:29:25 [16954:0] ../../src/mgr/install/pkgmgr.cpp:56 [1mTRACE List 'nginx' found 1[0m
    Mar 16 02:29:25 [16954:0] [1;36mEXTINFO Execute (/usr/bin/dpkg-query --showformat='${Status} ${Package} ${Version}
    ' -W '*'|/bin/egrep '^(install|hold) ok installed '|/usr/bin/cut -d' ' -f4,5) return=0 exited[0m
    Mar 16 02:29:25 [16954:0] ../../src/mgr/install/pkgmgr.cpp:83 [1mTRACE Has 'nginx' not found[0m
    Mar 16 02:29:25 [16954:0] ../../src/mgr/install/pkgmgr.cpp:56 [1mTRACE List 'nginx-stable' found 1[0m
    Mar 16 02:29:25 [16954:0] ../../src/mgr/install/pkgmgr.cpp:83 [1mTRACE Has 'nginx-stable' not found[0m
    Mar 16 02:29:25 [16954:0] ../../src/mgr/install/pkgmgr.cpp:83 [1mTRACE Has 'fcgi' not found[0m
    Mar 16 02:29:25 [16954:0] [1;36mEXTINFO Execute (export DEBIAN_FRONTEND=noninteractive; export PATH=/bin:/sbin:/usr/bin:/usr/sbin; apt-get --allow-unauthenticated -qy install 'nginx') return=100 exited[0m
    Mar 16 02:29:25 [16954:0] [1;36mEXTINFO Execute (/usr/bin/dpkg-query --showformat='${Status} ${Package} ${Version}
    ' -W '*'|/bin/egrep '^(install|hold) ok installed '|/usr/bin/cut -d' ' -f4,5) return=0 exited[0m
    Mar 16 02:29:25 [16954:0] [1;31mFATAL nginx-1.1.16-1 not installed[0m 
    не очень понимаю в логах, потому и пишу здесь, кто скажет в чем дело?

  2. #2
    Banned
    Регистрация
    29.11.2011
    Сообщений
    108

    По умолчанию

    Укажите версию системы и панели.

  3. #3
    ISPsystem team
    Регистрация
    18.07.2011
    Сообщений
    256

    По умолчанию

    А так же добавьте "LogLevel 9" в ispmgr.conf
    выполните:

    echo 9 >> /usr/local/ispmgr/pkgctl.debug
    echo 9 >> /usr/local/ispmgr/ispmgr.debug

    Перезапустите панель и приведи вывод ispmgr.log и pkgctl.log с момента активации.

  4. #4
    Senior Member
    Регистрация
    14.03.2012
    Адрес
    Ukraine, Lviv
    Сообщений
    724

    По умолчанию

    эту проблему решил, но теперь новая проблема
    PHP код:
    Mar 16 15:02:41 6378:0] [1;32mINFO Using package manager 'Apt'[0m
    Mar 16 15
    :02:41 6378:0] ../../src/mgr/install/pkgctl.cpp:689 [1mTRACE Init way[0m
    Mar 16 15
    :02:41 6378:0] ../../src/mgr/install/pkgctl.cpp:691 [1mTRACE Init client[0m
    Mar 16 15
    :02:41 6378:0] ../../src/mgr/install/pkgctl.cpp:697 [1mTRACE Done[0m
    Mar 16 15
    :02:41 6378:0] ../../src/mgr/install/pkgctl.cpp:536 [1mTRACE LoadModule lib/pkgisp-fcgi.so[0m
    Mar 16 15
    :02:41 6378:0] [1;36mEXTINFO Execute (/bin/egrep -'^Package: |^Version: ' /var/lib/apt/lists/*_Packages) return=0 exited[0m
    Mar 16 15:02:44 [ 6378:0] ../../src/mgr/install/pkgmgr.cpp:56 [1mTRACE List 'libapache2-mod-fcgid' found 1[0m
    Mar 16 15:02:44 [ 6378:0] [1;36mEXTINFO Execute (/usr/bin/dpkg-query --showformat='${Status} ${Package} ${Version}
    ' -W '*'|/bin/egrep '^(install|hold) ok installed '|/usr/bin/cut -d' ' -f4,5) return=0 exited[0m
    Mar 16 15:02:44 [ 6378:0] ../../src/mgr/install/pkgmgr.cpp:78 [1mTRACE Has 'libapache2-mod-fcgid-2.2-1+lenny1'[0m
    Mar 16 15:02:44 [ 6378:0] ../../src/mgr/install/pkgctl.cpp:1141 [1;33mDEBUG Not found 'Option ApacheMPM ' in file etc/ispmgr.conf[0m
    Mar 16 15:02:45 [ 6378:0] [1;36mEXTINFO Execute (/usr/sbin/a2enmod fcgid) return=0 exited[0m
    Mar 16 15:02:50 [ 6378:0] ../../src/mgr/install/pkgmgr.cpp:56 [1mTRACE List 'libapache2-mod-fcgid' found 1[0m
    Mar 16 15:02:50 [ 6378:0] ../../src/mgr/install/pkgmgr.cpp:78 [1mTRACE Has 'libapache2-mod-fcgid-2.2-1+lenny1'[0m 
    сразу говорю apache2-mpm-itk у меня не стоит, стоит apache2-mpm-prefork
    но почему fastcgi не активируется не понимаю

  5. #5

    По умолчанию

    Цитата Сообщение от KapaTicT1989 Посмотреть сообщение
    эту проблему решил, но теперь новая проблема
    PHP код:
    Mar 16 15:02:41 6378:0] [1;32mINFO Using package manager 'Apt'[0m
    Mar 16 15
    :02:41 6378:0] ../../src/mgr/install/pkgctl.cpp:689 [1mTRACE Init way[0m
    Mar 16 15
    :02:41 6378:0] ../../src/mgr/install/pkgctl.cpp:691 [1mTRACE Init client[0m
    Mar 16 15
    :02:41 6378:0] ../../src/mgr/install/pkgctl.cpp:697 [1mTRACE Done[0m
    Mar 16 15
    :02:41 6378:0] ../../src/mgr/install/pkgctl.cpp:536 [1mTRACE LoadModule lib/pkgisp-fcgi.so[0m
    Mar 16 15
    :02:41 6378:0] [1;36mEXTINFO Execute (/bin/egrep -'^Package: |^Version: ' /var/lib/apt/lists/*_Packages) return=0 exited[0m
    Mar 16 15:02:44 [ 6378:0] ../../src/mgr/install/pkgmgr.cpp:56 [1mTRACE List 'libapache2-mod-fcgid' found 1[0m
    Mar 16 15:02:44 [ 6378:0] [1;36mEXTINFO Execute (/usr/bin/dpkg-query --showformat='${Status} ${Package} ${Version}
    ' -W '*'|/bin/egrep '^(install|hold) ok installed '|/usr/bin/cut -d' ' -f4,5) return=0 exited[0m
    Mar 16 15:02:44 [ 6378:0] ../../src/mgr/install/pkgmgr.cpp:78 [1mTRACE Has 'libapache2-mod-fcgid-2.2-1+lenny1'[0m
    Mar 16 15:02:44 [ 6378:0] ../../src/mgr/install/pkgctl.cpp:1141 [1;33mDEBUG Not found 'Option ApacheMPM ' in file etc/ispmgr.conf[0m
    Mar 16 15:02:45 [ 6378:0] [1;36mEXTINFO Execute (/usr/sbin/a2enmod fcgid) return=0 exited[0m
    Mar 16 15:02:50 [ 6378:0] ../../src/mgr/install/pkgmgr.cpp:56 [1mTRACE List 'libapache2-mod-fcgid' found 1[0m
    Mar 16 15:02:50 [ 6378:0] ../../src/mgr/install/pkgmgr.cpp:78 [1mTRACE Has 'libapache2-mod-fcgid-2.2-1+lenny1'[0m 
    сразу говорю apache2-mpm-itk у меня не стоит, стоит apache2-mpm-prefork
    но почему fastcgi не активируется не понимаю
    Выполните установку fastcgi, через ssh, и увидите, на что ругается.

  6. #6
    Senior Member
    Регистрация
    14.03.2012
    Адрес
    Ukraine, Lviv
    Сообщений
    724

    По умолчанию

    она была установлена, но почему-то не включалась через возможности, пришлось включить через конфиг ISPmgr, и она почему-то начала нормально создавать домены и норм работать, не пойму почему но вся проблема началась после обновления nginx из панели(после перевода апача и прокси на 81 порт)

Ваши права

  • Вы не можете создавать новые темы
  • Вы не можете отвечать в темах
  • Вы не можете прикреплять вложения
  • Вы не можете редактировать свои сообщения
  •